Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,780,303 Members 42,691 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Very strange battery behavior.

Tip us?
 
parseval43
Old
(Last edited by parseval43; 7th July 2014 at 11:03 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Jul 2014
Location: Munich
Default [Q] Very strange battery behavior.

Hi all... first post, first problem with android... and hopefully a long time here in xda!

So I have the T320 (8.4 pro) and I have a strange problem with my battery. Is not only that it lasts no more than 4 hours (screen), the problem come by low and high battery %.

FOTO

By low, the table shuts down and after starting it again, it shows between 5 and 10% battery!!
Something similar happens by charging... it shows 90% and no change... and after a reboot it shows 100%.

Is my battery dying? Should I wipe and restart from zero? Cyanogen?

The speed how fast battery drains is also extreme compared to stand-by times... but I assume this is more or less a problem of this tablet.

Many thanks in advance!
 
cdjaney
Old
#2  
Senior Member
Thanks Meter 141
Posts: 603
Join Date: Feb 2012
Quote:
Originally Posted by parseval43 View Post
Hi all... first post, first problem with android... and hopefully a long time here in xda!

So I have the T320 (8.4 pro) and I have a strange problem with my battery. Is not only that it lasts no more than 4 hours (screen), the problem come by low and high battery %.

FOTO

By low, the table shuts down and after starting it again, it shows between 5 and 10% battery!!
Something similar happens by charging... it shows 90% and no change... and after a reboot it shows 100%.

Is my battery dying? Should I wipe and restart from zero? Cyanogen?

The speed how fast battery drains is also extreme compared to stand-by times... but I assume this is more or less a problem of this tablet.

Many thanks in advance!
Having similar issues. Found mine dead out of nowhere one day. Never had custom ROM on it. Did factory reset now it seems like it doesn't want to charge .... Charges VERY slowly if at all.

Sent from my SM-G900T using XDA Free mobile app
 
cletusarrarr
Old
#3  
cletusarrarr's Avatar
Senior Member
Thanks Meter 46
Posts: 776
Join Date: Apr 2009
i have the same issue, dropped from 50 to 15 all of a sudden , will try calibration , anyone else noticed this ?i picked up mine used so unsure whats the issue
 
fletch33
Old
#4  
fletch33's Avatar
Senior Member
Thanks Meter 257
Posts: 917
Join Date: Jan 2010
i found better battery life after i did a factory reset. i bought it new and set it up and since then had 1 Sammy update but last week i reset it and it clearly made a difference on my 10.1. yesterday i had 2 hours screen time and on battery for 2 day and some hours and had 60% left.
 
dottat
Old
#5  
dottat's Avatar
Recognized Contributor
Thanks Meter 793
Posts: 2,011
Join Date: Jan 2011
Location: york, pa

 
DONATE TO ME
Add mine to the list....seems to be doing the same thing here. Haven't been able to sort it out yet.
 
dottat
Old
#6  
dottat's Avatar
Recognized Contributor
Thanks Meter 793
Posts: 2,011
Join Date: Jan 2011
Location: york, pa

 
DONATE TO ME
Took the back off mine tonight and reseated the battery connector. Then charged like below. First to time in a while it charged up like this.


The Following User Says Thank You to dottat For This Useful Post: [ Click to Expand ]
 
cletusarrarr
Old
#7  
cletusarrarr's Avatar
Senior Member
Thanks Meter 46
Posts: 776
Join Date: Apr 2009
can you post a pic of videos of how to pry it open ? hopefully simple with a prying tool
 
dottat
Old
#8  
dottat's Avatar
Recognized Contributor
Thanks Meter 793
Posts: 2,011
Join Date: Jan 2011
Location: york, pa

 
DONATE TO ME
Quote:
Originally Posted by cletusarrarr View Post
can you post a pic of videos of how to pry it open ? hopefully simple with a prying tool
I just very carefully went around it with one of those guitar like plastic openers i have laying around from the many tablet/phone repair kits i have used. I probably rebooted it 5 times before i finally popped it apart... thing just did not want to charge. This was the first time i saw it ramp up 1% at a time in a while. The other thing i noticed it was doing was jumping from ~70% to 100% instantly.... The graph showed it too. I didn't believe that was really happening.
 
cletusarrarr
Old
#9  
cletusarrarr's Avatar
Senior Member
Thanks Meter 46
Posts: 776
Join Date: Apr 2009
some pics would help , is it between the screen and the metallic part or the back and the metallic part ?
 
dottat
Old
#10  
dottat's Avatar
Recognized Contributor
Thanks Meter 793
Posts: 2,011
Join Date: Jan 2011
Location: york, pa

 
DONATE TO ME
Quote:
Originally Posted by cletusarrarr View Post
some pics would help , is it between the screen and the metallic part or the back and the metallic part ?
No. The faux leather cover comes off.

This... http://forum.xda-developers.com/show....php?t=2710711

pro 8.4 Teardown

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes