Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,727 Members 52,666 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Trouble getting USB OTG hub working

Tip us?
 
aleson
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Mar 2012
Default [Q] Trouble getting USB OTG hub working

I'm trying to get a USB OTG hub I bought working with the 10.5 tab s (SM-T805). I can't post a link to the hub, but if you search ebay for 'EZI - Universal 7-IN-1 USB Hub Micro SD TF Card Reader for OTG Smart Phone' you should see it, it's a square one that also reads SD cards.

It works fine with my S4 using stickmount pro, but when I plug it into the tab S the power light on the hub comes on, but the second I plug a USB stick (1Gb USB 2.0) in the light goes out, and nothing happens.

Does anyone have any suggestions to get it working, or can they recommend a USB hub that does work with the Tab S?

Thanks
 
pop up
Old
#2  
Junior Member
Thanks Meter 1
Posts: 8
Join Date: Jun 2007
Quote:
Originally Posted by aleson View Post
I'm trying to get a USB OTG hub I bought working with the 10.5 tab s (SM-T805). I can't post a link to the hub, but if you search ebay for 'EZI - Universal 7-IN-1 USB Hub Micro SD TF Card Reader for OTG Smart Phone' you should see it, it's a square one that also reads SD cards.

It works fine with my S4 using stickmount pro, but when I plug it into the tab S the power light on the hub comes on, but the second I plug a USB stick (1Gb USB 2.0) in the light goes out, and nothing happens.

Does anyone have any suggestions to get it working, or can they recommend a USB hub that does work with the Tab S?

Thanks
Hi,

No suggestions to make yours work, but here is a product which seems to be working (USB host and charge simultaneously) :

http://lavalink.com/products/samsung...r-tab4-tabpro/

Quentin
The Following User Says Thank You to pop up For This Useful Post: [ Click to Expand ]
 
aleson
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Mar 2012
Thanks, I may take a look at that, I've ordered another OTG 'hub' (one with several cables coming off the main plug) that does accept power in, I'm hoping that will work... If not I'll be trying the one you suggest.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes