Post Reply Subscribe to Thread Email Thread

USB problems...

6th July 2014, 10:49 PM |#1  
OP Senior Member
Thanks Meter: 40
 
221 posts
Join Date:Joined: Apr 2010
This is really strange. I can't connect my new Tab S 10.5 to my imac with the usb cable. I've replaced the cable and power brick but to no avail. When I connect the device to the power, there's a small red "x" on the battery icon and no charge is going on. But when I use the same cable and charger on my S5 it works, charges and connects to my imac. What am I doing wrong with the tab s?
 
 
7th July 2014, 12:26 AM |#2  
HughesNet's Avatar
Senior Member
Thanks Meter: 246
 
873 posts
Join Date:Joined: Apr 2013
Expecting its charging needs to match your phone...
7th July 2014, 09:10 AM |#3  
Junior Member
Thanks Meter: 1
 
12 posts
Join Date:Joined: Jun 2008
I believe that the red x on the battery indicator shows that the USB source does not meet the power requirements to charge the device (can't deliver enough current).

I get this when I plug my Tab S 8.4 into my monitor USB port (PC not Mac), but it doesn't stop my Tab S from connecting via USB. So while I have the red x I can still transfer files to and from the device and it doesn't seem to loose any charge, it won't recharge. I hope that makes sense!

I think that the connection problem that you are seeing and the red x are unrelated.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes