APKTool Updated with Android Lollipop Support

One of the beauties of Android is the level of flexibility we have over our devices. Whether … more

Lollipop Leak for Sprint Galaxy S5, TWRP for Micromax Canvas Magnus – XDA TV

Android 5.0 Lollipop has been leaked for the Sprint … more

Velocity is Like OpenTable on Steroids

We all enjoy a night out with friends or our significant other from time to time. However, there is … more

Android Lollipop Lands for the Sony Xperia Z Ultra

The undisputed king of the beasts–at least in Sony’s current stable,is the … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Micro SD-Card Problem

OP folkbytes

8th August 2014, 08:50 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2014
Greetings everyone,

I tried finding a solution for this problem for quiet a while now already, but I simply can't find one.
I have a 64gb sdxc card by Sandisk and it doesn't work properly anymore.

The problem is, that it restores the partition always over and over again when I try to partition or format the sd card.
Like when I delete the partition and apply the changes and the card is beeing mounted again, it shows the same partition with the same files again before I deleted it.

Is there a way to fix this? Because except from that problem it works as it should.
Could it be that write protection issue I've read about here?
It first appeared when I used Omnirom for a while on my S3

Thanks in advance for your help
10th August 2014, 10:46 PM   |  #2  
Member
Thanks Meter: 2
 
41 posts
Join Date:Joined: Aug 2014
Quote:
Originally Posted by folkbytes

Greetings everyone,

I tried finding a solution for this problem for quiet a while now already, but I simply can't find one.
I have a 64gb sdxc card by Sandisk and it doesn't work properly anymore.

The problem is, that it restores the partition always over and over again when I try to partition or format the sd card.
Like when I delete the partition and apply the changes and the card is beeing mounted again, it shows the same partition with the same files again before I deleted it.

Is there a way to fix this? Because except from that problem it works as it should.
Could it be that write protection issue I've read about here?
It first appeared when I used Omnirom for a while on my S3

Thanks in advance for your help

How old is the card? Any noticeable cracks, burns, or damage to the contact on the card?
10th August 2014, 11:12 PM   |  #3  
digijedi007's Avatar
Senior Member
Thanks Meter: 36
 
116 posts
Join Date:Joined: May 2014
More
Your card might be bad, I have had a bad experience with sandisk memory cards , i bought one and had to exchange it 5 times for a new one , finally i did get a reliable one.So if possible see If you can return it
10th August 2014, 11:38 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2014
Not sure how old the card is. Should be around a year I think.
The card has no damages from the outside. The pc can read it too, same for my phone. I can't write files on it or format it or delete partition.
When I remove the card and put it back into the reader, it has the same status as before I changed it.

I read too, that sandisk seems to have problems with their cards lately. Especially this 64gig model.
I guess too that it is really bad and no good anymore.
10th August 2014, 11:41 PM   |  #5  
digijedi007's Avatar
Senior Member
Thanks Meter: 36
 
116 posts
Join Date:Joined: May 2014
More
You should at least be able to return it since sandisk has a lifetime warranty (and seeing as there is not physical damage they will probably replace it with a bit of convincing)
12th August 2014, 04:13 AM   |  #6  
Member
Thanks Meter: 9
 
52 posts
Join Date:Joined: Jul 2014
As convenient as SD/micro's can be, they seem to have plenty of issues like this. Certain brands work wonders for some people and some are lemons. I've always had a good experience with Sandisk, but see if they'll replace it or check out Kingston or Transcend or another brand.
13th August 2014, 01:38 AM   |  #7  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2014
I'm gonna do that. Thanks for the help so far.
13th August 2014, 08:44 AM   |  #8  
datphu2811's Avatar
Member
Flag Tuy Hoa
Thanks Meter: 78
 
70 posts
Join Date:Joined: Aug 2014
Donate to Me
More
Solved!
Quote:
Originally Posted by folkbytes

I'm gonna do that. Thanks for the help so far.

Try repair by MMC Medic app.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes