Remove All Ads from XDA

Lexibook Tablet "Barbie" recovery

22 posts
Thanks Meter: 3
By gary.swallow, Junior Member on 27th August 2014, 11:37 PM
Post Reply Subscribe to Thread Email Thread
Thought I would share my experience with this PITA tablet.
Just spent a few days scratching my head trying to factory reset a Lexibook Barbie MFC190BBEN model Android tablet.
It belongs to a 7 year old girl who put a password lock on it for some reason then forgot her password (much to her Mum's annoyance).

The Lexibook support site suggests going into settings and selecting factory reset.
Obviously this cannot be done as the tablet is locked so their next suggestion is to send it back for 'out of warranty' repair!

Some serious googling got me as far as recovery mode (sort of) which involves the reset button being pressed with a paperclip whilst pressing the power button and volume up at the same time whilst connected to a pc via usb.
This gets you a blank tablet screen, adb access but no fastboot and the adb is very limited and stops responding to simple commands.
It uses a Rockchip processor but most of the drivers do not give a stable connection.

After lots of trying to get stable connections so I can push a custom recovery (or get anything at all to talk to the damn tablet) I found that if you disonnect the usb cable and reset the tablet with the reset button you need to hold BOTH volume buttons then press the power button for a couple of seconds..keep holding the volume buttons and you should get the Android robot with a red exclamation mark.

From here I reconnected to the pc and adb could now see a device in recovery mode but with a serial of 0123456789ABCDEF

Still no joy with any adb commands....
Just a few reboots to blank screen again with no adb.

So I reset again and held the two volume buttons to get back to the Android with red exclamation mark again.

Some more googling found a different type of Rockchip based tablet that suggested NOW pressing the power button and volume up quickly..........

Well it turns out this tablet DOES have its own recovery!!!

No amount of googling told me this!!

So after days of messing about with drivers and button presses it turns out it is a simple task to reset from recovery.

You use the volume keys to choose from the minimal options in the recovery menu and use power to select.

Due to the amount of googling I did with no answers that worked (or even came close to an answer) I thought I would share this in the hope it would save someone else from pulling their hair out and keep their child happy!

Last edited by gary.swallow; 27th August 2014 at 11:54 PM.
8th February 2015, 10:04 AM |#2  
Junior Member
Flag Brno
Thanks Meter: 1
you're legend, mate ... I've been trying to put google services and youtube on it for ages. Now it seems it can be done!
16th October 2015, 09:03 PM |#3  
Junior Member
Thanks Meter: 0
No mater how i press the buttons the android robot never appears just the normal start screen please describe the key pressing combination again
29th October 2015, 10:45 AM |#4  
gary.swallow's Avatar
OP Junior Member
Flag Louth, Lincolnshire
Thanks Meter: 3
Press the reset button with a paperclip whilst you hold BOTH volume buttons then press the power button for a couple of seconds.
Keep holding the volume buttons and you should get the Android robot with a red exclamation mark.
NOW press the power button and volume up quickly..
This should get you into 'recovery'
The Following User Says Thank You to gary.swallow For This Useful Post: [ View ] Gift gary.swallow Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes