Post Reply

[help] ART broke my apps switched back to dalvik but apps still broken

OP DalvikArt

29th July 2014, 11:40 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
Hi i am new this is my first post.
I have updated my chinese phone (rebranded here in our country) from JB to KK i heard about ART and the advantages so i tried switching to ART.

when my phone was still on JB viper4android works well, rom toolbox lite, worked fine until i upgraded to KK and switched to ART runtime now my apps wont work. i have a read post here in xda that many apps including Xposed Framework wont work with kk's ART runtime. Viper wont install driver even i hav busybox installed, romtoolbox goes FC. so I switched back to Dalvik but same thing happens apps go FC.
Please help i want to know if this apps are broken by ART runtime or broken by KK update.
another question. Does KK make my rom Deodexed? Thank you very much. sorry for my bad english

i tried to do factory reset in cwm recovery but still same problem arise.
p.s i have upgraded my phone via OTA. i brought back everything to stock before the OTA upgrade. so its a clean upgrade..
29th July 2014, 12:39 PM   |  #2  
TechMinerUK's Avatar
Senior Member
Thanks Meter: 52
 
292 posts
Join Date:Joined: Jun 2013
More
Sounds like they were broken by the update as usualy when you revert back to Dalvik they work again.

I know its a pain but the best soloution to this is back up your data, reset your phone and reinstall the apps from play store and data from your backup.

Also KitKat as far as I'm aware does not come de-odexed, you have to find de-odexed ROMs or de-odex them manually
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Questions and Answers by ThreadRank