FORUMS

[Q] Help with port connection (ftp server ultimate)

23 posts
Thanks Meter: 7
 
By scottayy, Junior Member on 10th July 2015, 02:40 AM
Post Reply Subscribe to Thread Email Thread
Hmm i just posted this but can't find it anywhere. Apologies if double posted or it was deleted for some reason.

The target device:
No mobile network connection, it is on wifi only
Cm12.1
Static ip

General info:
Forwarded port through my router configuration page
Canyouseeme.org reports port is open on public ip

Problem:
Can connect via internal ip from other devices but when i switch to public ip the connection times out.
I did have the port forwarding configured wrong but now the port is open. Before it would refuse the connection. Now it just times out after waiting 3000ms.

Is there and Android setting preventing port connections?

Images:

Canyouseeme.org reports open port


failure message from ftp client on android device


Also fails from my regular ftp program via windows box
Last edited by scottayy; 10th July 2015 at 03:04 AM.
 
 
10th July 2015, 05:58 AM |#2  
OP Junior Member
Thanks Meter: 7
 
More
One thing that concerns me is my router lists my device as having a dhcp connection. The device connection is implicitly set to static and always uses the ip address i assigned it. It very much acts static but the router says dhcp. I don't think this is the problem. But it's still concerning.

Edit: terminal emulator using netstat confirms port 33133 is listening via tcp6

Edit 2: the problem is probably the device is listening using ipv6 and I'm trying to connect with my ipv4 address.

How can i force android to connect using ipv4, or connect to my device using ipv6 address? Admittedly i don't know much about ipv4 or ipv6.

Edit 3: I reset router and set up port forwarding again. Reset static ip to a different ip. Turned off ipv6 in router. The router now recognizes my device as static instead of dhcp. Changed the port number and canyouseeme.org sees the new port as open. However, ftp client still gets connection timed out error. netstat on the server device still recognizes that it's listening via tcp6 on the port (ipv6) which I suspect is the problem. I need to force my android ftp server device to connect with ipv4.
Last edited by scottayy; 10th July 2015 at 07:43 AM.
10th July 2015, 10:07 PM |#3  
OP Junior Member
Thanks Meter: 7
 
More
This is seriously giving me a headache! I bought a 5tb drive to connect via usb host cable and need the ftp server to keep offsite database backups of my websites. So, it's pretty important to me.

Anyways, I've disabled ipv6 at the router level and phone level (via app and script). Netstat still reports tcp6 listening.

Is this even the problem? It seems ipv6 is pretty popular on Android and the problem persists across multiple ftp server apps. Seems like the apps would be built with this in mind. I'm trying on my android 2.3 phone as well but i can't find how to make a static ip on gingerbread.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes