Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,340 Members 43,369 Now Online
XDA Developers Android and Mobile Development Forum

Pesky insufficient storage error, with a new twist?

Tip us?
 
irha
Old
#1  
Senior Member - OP
Thanks Meter 24
Posts: 120
Join Date: Nov 2010
Default Pesky insufficient storage error, with a new twist?

I know, there are literally hundreds of threads all over the net for this error, but many got it solved by doing one or the other, such as clearing caches, removing odex files, fixing permissions, changing the default installation location to SD, installing via apk, etc., but none of them are working for me. I can't even update SuperSU which is a mere 2.23MB in size. However, this only started very recently, after having been in use for about 3 months and installing and updating apps successfully during this time.

First of all, let me be clear that the issue doesn't seem to be with the disk space. I have plenty of space on all partitions:
Code:
1|root@android:/ # df
Filesystem                 Size         Used         Free    Blksize
/dev                    402.14M       64.00K      402.08M       4096
/system                   1.19G      713.55M      501.12M       4096
/mnt/asec               402.14M        0.00K      402.14M       4096
/mnt/obb                402.14M        0.00K      402.14M       4096
/data                     1.27G      673.40M      628.08M       4096
/sns                      7.91M        4.11M        3.80M       4096
/mpt                     31.54M        5.60M       25.94M       4096
/persist-lg               7.91M        4.14M        3.77M       4096
/cache                  788.39M       14.54M      773.86M       4096
/persist                  7.91M        4.10M        3.81M       4096
/firmware                63.95M       41.80M       22.16M      16384
/storage/sdcard0          1.27G      673.40M      628.08M       4096
/storage/external_SD     58.55G        4.55G       53.99G      32768
/mnt/secure/asec         58.55G        4.55G       53.99G      32768
However, when I try to update SuperSU and run ls -l on /data/data/com.android.providers.downloads/cache directory, I see that the file gets downloaded exactly to the size of 541495 before play store gives me the dreaded error. When I tried to update Play Services (16.18MB), the download exactly stops at 8200630 before giving insufficient storage error. I verified this several times, by removing the partial files and attempting to install again and every time, the download stops at exactly the same size. The partition of course has plenty of space as can be seen from above.

Code:
root@android:/data/data/com.android.providers.downloads/cache # ls -l
-rw-r--r-- u0_a19   u0_a19     541495 2014-08-14 22:43 downloadfile-1.bin
-rw-r--r-- u0_a19   u0_a19    8200630 2014-08-14 22:38 downloadfile.bin
I was able to install some really small installs successfully, but that is also not very consistent. I also tried to install apk directly using adb, and that too fails with the same error:

Code:
$ ./adb install -r /tmp/Google\ Play\ Services.apk
3627 KB/s (18901801 bytes in 5.088s)
	pkg: /data/local/tmp/Google Play Services.apk
Failure [INSTALL_FAILED_INSUFFICIENT_STORAGE]
I captured logcat while trying to install apk and it had the below warning:

Code:
W/ActivityManager(  569): No content provider found for permission revoke: file:///data/local/tmp/Google Play Services.apk
Someone suggested that this would happen if the permissions on /data/local doesn't include write and execute perms for others, and sure enough I had the issue, so I fixed the perms, but it neither took the above warning away nor the insufficient storage error. I also of course tried to copy the apk to phone and install it by opening it with a filemanager.

Could someone please help me troubleshoot this issue further? At this point, I have uninstalled at least 10 apps to clear up more than 200MB, and yet I can't update a mere 2MB app and neither can restore any of those apps back with TitaniumBackup (TB restore just never completes). I didn't try factory restore yet, but would like to keep that to the end, since I will end up losing the root, and I am not sure if I can root it again (I had to struggle for it the last time)

Phone Model: LG Optimus F6 (T-Mobile)
Android version: 4.1.2 (stock, rooted, debloated)
Build number: JZ054K
Software Version: D50010h
 
irha
Old
#2  
Senior Member - OP
Thanks Meter 24
Posts: 120
Join Date: Nov 2010
Instead of doing a factory reset as recommended in some threads, I ended up restoring a CWM backup from 3 months back and then restoring the individual app data along with SMS and call log using TiB. This helped me get rid off this pesky error, at least for now. I was able to update all the apps and I took a fresh new CWM backup immediately, in case I need to repeat this in the future.

BTW, the download size of the apk seems to be always smaller than what is indicated in its description. When the download files in the play store cache always appeared smaller than its indicated size, it appeared like the download was getting aborted. I should have probably pulled one of those files out and verified it as a zip file, but the problem must be with the installation. After all I didn't succeed installing an apk that I downloaded separately.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes