Default Safestrap RomSlot Crashes When Link2SD Selected Ext4 Partition as 2nd Partition

i had to take out battery after crash to shut it down

could this be because i havent got supersu installed? ( from what ive heard supersu doesnt affect root properties only disallows permission)

ive searched and one xda member said they fixed safestrap romslot crashes w link2sd
by uninstalling safestrap unrooting rerooting etc.(i forgot rest) - it was a tedious process and idk if it would work for me as i didnt understand how redoing everything helped fix the problem

the problem is specificly with the 2nd partition linking while in romslot

also unrelated (this happened before i installed link2sd on romslot) when i reboot from romslot it stops on "android" startup screen from the custom rom im using

i booted to stock rom after romslot crashed
when i tried to boot to romslot after link2sd tried to link partition and rebooted to romslot it got stuck on "android" loading screen from my custom rom basicly, it wouldnt boot in to the rom but got stuck
i had to take out battery and boot into safestrap recovery after

& when i tried to boot to romslot after phone shut down it stiill gets stuck @ "android" loading screen everytime