Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] SD card cannot be detected when browsing as root.

OP ocenyx

26th August 2014, 09:13 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Dec 2013
Good day, fellow XDA citizens.

Here's my problem. My phone's external storage cannot be detected by apps when they are browsing as root. See screens:

This is what it looks like when the apps are browsing as root: (i.e. granted su permissions)



This is what it looks like when the apps are not browsing as root: (and the way things are supposed to be)



Note that these issues are not limited only to this Script Manager app, but others as well, including Android Tuner, TiB, and the likes (most apps that access the external storage)

I've noticed that fuse in external storage becomes "RO rootfs" when browsing as root, and fuse remains intact for internal storage whether or not it was given su permissions.

I've tried googling around for answers, a few articles and discussions mention fuse but I can't make a certain sense out of them, most likely because I am a scrub on linux usage.

What things can I do to try fix this issue? Any help will be much appreciated.

regards, Ocenyx
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-08-26-14-58-34.png
Views:	784
Size:	50.0 KB
ID:	2912611   Click image for larger version

Name:	Screenshot_2014-08-26-14-58-40.png
Views:	768
Size:	17.1 KB
ID:	2912612   Click image for larger version

Name:	Screenshot_2014-08-26-14-58-56.png
Views:	755
Size:	47.8 KB
ID:	2912613   Click image for larger version

Name:	Screenshot_2014-08-26-14-58-59.png
Views:	761
Size:	94.2 KB
ID:	2912614  
Last edited by ocenyx; 26th August 2014 at 09:21 AM.
26th August 2014, 10:35 AM   |  #2  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
SD card not detected
I have Samsung Wave2 GT-s8530. whenever I am installing badadroid on my set whatever the ROM is my external SD card was not detected. it showed 0 MB only. Details of my phone and installation as follows:
Installed at Downloader v5.67
Fat32 is the format of SD card.
26th August 2014, 11:29 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Dec 2013
Anyone please?

By the way, this phone is running 4.4.2 version of Android. This issue was not present in 4.2.2 before.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes