[Q] SD card cannot be detected when browsing as root.

7 posts
Thanks Meter: 0
By ocenyx, Junior Member on 26th August 2014, 09:13 AM
Post Reply Subscribe to Thread Email Thread
Good day, fellow XDA citizens.

Here's my problem. My phone's external storage cannot be detected by apps when they are browsing as root. See screens:

This is what it looks like when the apps are browsing as root: (i.e. granted su permissions)

This is what it looks like when the apps are not browsing as root: (and the way things are supposed to be)

Note that these issues are not limited only to this Script Manager app, but others as well, including Android Tuner, TiB, and the likes (most apps that access the external storage)

I've noticed that fuse in external storage becomes "RO rootfs" when browsing as root, and fuse remains intact for internal storage whether or not it was given su permissions.

I've tried googling around for answers, a few articles and discussions mention fuse but I can't make a certain sense out of them, most likely because I am a scrub on linux usage.

What things can I do to try fix this issue? Any help will be much appreciated.

regards, Ocenyx
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-08-26-14-58-34.png
Views:	850
Size:	50.0 KB
ID:	2912611   Click image for larger version

Name:	Screenshot_2014-08-26-14-58-40.png
Views:	836
Size:	17.1 KB
ID:	2912612   Click image for larger version

Name:	Screenshot_2014-08-26-14-58-56.png
Views:	825
Size:	47.8 KB
ID:	2912613   Click image for larger version

Name:	Screenshot_2014-08-26-14-58-59.png
Views:	831
Size:	94.2 KB
ID:	2912614  
Last edited by ocenyx; 26th August 2014 at 09:21 AM.
26th August 2014, 10:35 AM |#2  
Junior Member
Thanks Meter: 0
SD card not detected
I have Samsung Wave2 GT-s8530. whenever I am installing badadroid on my set whatever the ROM is my external SD card was not detected. it showed 0 MB only. Details of my phone and installation as follows:
Installed at Downloader v5.67
Fat32 is the format of SD card.
26th August 2014, 11:29 AM |#3  
OP Junior Member
Thanks Meter: 0
Anyone please?

By the way, this phone is running 4.4.2 version of Android. This issue was not present in 4.2.2 before.
22nd November 2014, 04:05 PM |#4  
OP Junior Member
Thanks Meter: 0
To anyone else having this issue,

It seems to be a well-known symptom of Kitkat for MT6582 devices. I'm not certain if this problem exists on any other chip.

While we wait for any official fix for SuperSU app regarding this issue (if any), the only fix I have ever known to have worked is by using KingRoot. I'm aware that many advanced android people always discourage users from installing chinese stuff but it addresses the issue at least. It's much much better than living through this inconvenience.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes