Post Reply

Two Tablets Broken for no reason?

OP Trozzul

8th August 2014, 03:43 PM   |  #1  
So within the last week or two, i have had two of my tablets Break for now reason with no signs of life (recovery mode/charging). i had a Samsung Galaxy tab 2 10.1 that went first, its a little older and was running Cyanogenmod 11 so i thought it was just close to the end of its life so i set it aside and went to my Nexus 7 2012, Now this thing was not running a Custom rom and still shows no sign of life, both of the devices sat next to my bed on a sort of desk thing so i am able to easily reach for it, recently i have decided to stop keeping my galaxy tab 2 on charge all night/day so i would probably charge it every two nights. i did the same with the nexus 7, i have no idea how they are broken i have let them sit on charge for hours but still nothing, any ideas?
9th August 2014, 02:05 AM   |  #2  
jrc2's Avatar
Senior Member
Thanks Meter: 232
 
911 posts
Join Date:Joined: Nov 2013
Donate to Me
More
Quote:
Originally Posted by Trozzul

So within the last week or two, i have had two of my tablets Break for now reason with no signs of life (recovery mode/charging). i had a Samsung Galaxy tab 2 10.1 that went first, its a little older and was running Cyanogenmod 11 so i thought it was just close to the end of its life so i set it aside and went to my Nexus 7 2012, Now this thing was not running a Custom rom and still shows no sign of life, both of the devices sat next to my bed on a sort of desk thing so i am able to easily reach for it, recently i have decided to stop keeping my galaxy tab 2 on charge all night/day so i would probably charge it every two nights. i did the same with the nexus 7, i have no idea how they are broken i have let them sit on charge for hours but still nothing, any ideas?

Were they both plugged in when this happened? Maybe a power surge?

Sent from my SGH-T989
9th August 2014, 04:11 AM   |  #3  
Quote:
Originally Posted by jrc2

Were they both plugged in when this happened? Maybe a power surge?

Sent from my SGH-T989

sorry i tried to explain that they were not infact on charge when i found them, i charge my phone every night and its still working, i have one of the protectors so it does not fry.
9th August 2014, 12:49 PM   |  #4  
jrc2's Avatar
Senior Member
Thanks Meter: 232
 
911 posts
Join Date:Joined: Nov 2013
Donate to Me
More
Quote:
Originally Posted by Trozzul

sorry i tried to explain that they were not infact on charge when i found them, i charge my phone every night and its still working, i have one of the protectors so it does not fry.

Weird. I don't know then.

Sent from my SGH-T989
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Questions and Answers by ThreadRank