Default What version GAAPS?

I have a version of android 2.3.1, kernel version 2.6.32.27. What version GAAPS need? What do I need to upload to run android market? GoogleServiceFramework & Vending enough?
[emoji780] [emoji780] [emoji780]
8) BaGRoS 8)