Post Reply

WiFi wont turn on after flash!

OP Vohukain

21st August 2014, 07:07 AM   |  #1  
OP Member
Thanks Meter: 5
 
48 posts
Join Date:Joined: Apr 2014
More
Hi!
I have an android tablet but I don't know exactly what device it is. Here is everything what I have found:
 
-Brand: RK3026
-Model: Q8
-Android: 4.2.2 (SDK: 17)
-Kernel: Linux version 3.0.36+ (lijian@ibm-0A) (gcc version 4.6.x-google 20120106 (prerelease) (GCC)) #69 SMP PREEEMPT Thu Jan 16 15:50:05 HKT 2014
-Number of the version of the software: rk3026-eng 4.2.2 JDQ39 eng.lijian.20140107.155201 test-keys
-CPU Model: Rockchips Cortex-A9 (Dual Core, freq: 312-1008MHz)
-Renderer: Mali-400 MP
-Resolution: 800x480
-Rear and front camera: 1,9 MP (1600x1200) and 0,3 MP (640x480)
-Ram: 512MB
-System storage: 0,98GB
-Internal storage: 1,90GB
-GPU version: OpenGL ES 2.0
Also I got some manual but there was only "MID Android". Tablet looks like THIS.

First I rooted my device with chinese program called Vroot. Then I installed TWRP and I made backup with it. Then I tried to flash this rom (made by Cash1977) but I didn't flash it with kernel partion so I ended up to a bootloop. Then I tried to restore TWRP backup but the I noticed that it was not proper. The system part size was only 4kt. When I did restore backup my TWRP said "no os installed are you sure you wish to reboot". When I rebooted it ended up to a bootloop again.

Then I tried to flash this rom (made by Oma) but it didn't work. I used rkandroidtool v1.37. First I think that I used wrong kernel so I tried with several kernels and got messed up device badly. I almost bricked it once for good but then I tried different tool called androidtool v2.1. Then I flash with Cash's rom and this kernel (3.0.36+ (lijian) #69) and device booted up nicely. Only porblem is now that wifi is not working

The issue: If I try to turn wifi bar on it will automatic slide to off position. It says that "turning wifi on" but nothing happens. When I go settings>advanced I noticed that mac address is unavailable. Also when I go settings>about tablet>status I found put that imei is unknow.

So far I have tried to flash different rom (the oma's one again) and it works perfectly but wifi not. I have also tried to restore my TWRP again but it says "no os installed". I have also tried to wifi fix app and FXR wifi fix app but they are not helping. FXR wifi fix stops when it says "reading profiles". Can anyone help me?

EDIT: I find this thead and there is the same problem! How I can find those same files (libhardware.so ,libhardware_legacy.so , rkwifi.ko, wlan.ko and 8188eu.ko) for my device. Is the any change that thay still are there somewhere in my TWRP backup?
EDIT2: I think that I find the problem. When I go to the /system/lib/modules/ I find there file named "rkwifi.ko.3.0.8+". I'm using kernel which is 3.0.36+ so I need module for 3.0.36+, right?

EDIT3: Here is the answer to my problem:

"Idea for fix wifi
Check in your stock. If your stock rom run module diver on environment with 3.0.36+ of wifi driver you must replace files to custom rom.
how to:
1. Replace libhardware.so and libhardware_legacy.so from stock rom in /system/lib/
2. Replace module driver files from stock rom in /system/lib/modules/
-8188eu.ko
-8188eu.ko.3.0.36+
-8192cu.ko
-8192cu.ko.3.0.36+
-rkwifi.ko
-rkwifi.ko.3.0.36+
-wlan.ko
-wlan.ko.3.0.36+
3. If another wifi chip make the same too for environment with 3.0.36+
4. If stay problem. to replace all files in folder /system/etc/firmware from stock rom to custom rom folder /system/etc/firmware

Hope to fix your problem.
sorry for bad english language.
Anucha. " Origanlly posted here

Where I can find those files for my device? Can I use just any file named like above?
Last edited by Vohukain; 25th August 2014 at 09:28 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Questions and Answers by ThreadRank