FORUMS

Introducing Voices of XDA: Have Your Ideas Heard

By far the greatest assets we have at XDA-Developers are you, the developers, the eager … more

Unofficial Xposed For Lollipop Touchwiz With Flashable Zip

XDA Recognized Developer arter97 has released an unofficial build … more

YotaPhone 2 Pre-Order, Xperia Z1 Price Cut – XDA TV

Android Wear 5.1.1 OTA downloads are now available. That and much more news is … more

[FTF] Sony Xperia Z Lollipop Release

Sony rolled out a Lollipop update for Xperia Z just yesterday. If you still haven’t gotten … more
Post Reply Subscribe to Thread Email Thread

[Q] Xperia Z stuck on black screen after sony logo

2nd August 2014, 08:30 AM |#1  
OP Junior Member
Thanks Meter: 0
 
More
ok,so i am using xperia Z for long time...updated it to official 4.4.2 (kitkat) i wanted to flash PureX audio on it to increase the speaker volume..!! so..i rooted it thorugh towel root app on playstore..!! and confirmed that its rooted through root checker...but was not able to enter custom recovery mode...so i downloaded some app for entering custom recovery and flash purex from sd card...then when i entered recovery mode and installed the purex n rebooted the phone....the phone started restarting from that purple screen on 4.4.2...then again i entered custom recovery and cleared the cache...but it did not helped me....then once again i entered recovery mode...i cleared dalvik cache....factory data...and 2-3 more options were there..and i cleared each and everything...i guess i cleared its OS too..!!...but then when i chose to reboot the device...there was a message saying your device is not rooted..."do u wish to root it"...i chose NO..!! n den it restarted saying no OS installed..!! n now when m trying to restart it...the sony logo comes up...den the black screen..!! i am not able to switch it off..!! until the battery is drained..!! pls help me..!! :'(
 
 
2nd August 2014, 09:44 AM |#2  
TechMinerUK's Avatar
Senior Member
Thanks Meter: 72
 
More
Quote:
Originally Posted by tpranay

ok,so i am using xperia Z for long time...updated it to official 4.4.2 (kitkat) i wanted to flash PureX audio on it to increase the speaker volume..!! so..i rooted it thorugh towel root app on playstore..!! and confirmed that its rooted through root checker...but was not able to enter custom recovery mode...so i downloaded some app for entering custom recovery and flash purex from sd card...then when i entered recovery mode and installed the purex n rebooted the phone....the phone started restarting from that purple screen on 4.4.2...then again i entered custom recovery and cleared the cache...but it did not helped me....then once again i entered recovery mode...i cleared dalvik cache....factory data...and 2-3 more options were there..and i cleared each and everything...i guess i cleared its OS too..!!...but then when i chose to reboot the device...there was a message saying your device is not rooted..."do u wish to root it"...i chose NO..!! n den it restarted saying no OS installed..!! n now when m trying to restart it...the sony logo comes up...den the black screen..!! i am not able to switch it off..!! until the battery is drained..!! pls help me..!! :'(

Sounds like you need to restore the stock ROM, just download it and flash using flash tool and your device will work again.

It appears the PureX audio may have corrupted the ROM and has prevent it from loading

Hope I could help
The Following User Says Thank You to TechMinerUK For This Useful Post: [ View ]
7th August 2014, 08:45 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
THANKYOU..!!
Quote:
Originally Posted by TechMinerUK

Sounds like you need to restore the stock ROM, just download it and flash using flash tool and your device will work again.

It appears the PureX audio may have corrupted the ROM and has prevent it from loading

Hope I could help

thanks....worked like a charm..! thanks again..!! u saved my phone.!!
8th August 2014, 10:09 AM |#4  
TechMinerUK's Avatar
Senior Member
Thanks Meter: 72
 
More
Quote:
Originally Posted by tpranay

thanks....worked like a charm..! thanks again..!! u saved my phone.!!

No problem, glad you got your phone working
7th February 2015, 04:08 PM |#5  
Junior Member
Thanks Meter: 0
 
More
I'd like to share my experience about, I had the same problem, what i do is to press power button and connect the phone to the computer (befere I tried to flash it with flashtools and I couldn't get the phone to enter to flashmode) a icon of the battery will appear, now start flashtool software (you should have the firmware downloaded previously) and follow all steps for reinstall android, this time flashtools recognize your phone.

I hope have helped, and sorry for my english I'm not english speaker.
7th February 2015, 06:56 PM |#6  
Junior Member
Flag bhilai.
Thanks Meter: 3
 
More
Cool try it
Quote:
Originally Posted by tpranay

ok,so i am using xperia Z for long time...updated it to official 4.4.2 (kitkat) i wanted to flash PureX audio on it to increase the speaker volume..!! so..i rooted it thorugh towel root app on playstore..!! and confirmed that its rooted through root checker...but was not able to enter custom recovery mode...so i downloaded some app for entering custom recovery and flash purex from sd card...then when i entered recovery mode and installed the purex n rebooted the phone....the phone started restarting from that purple screen on 4.4.2...then again i entered custom recovery and cleared the cache...but it did not helped me....then once again i entered recovery mode...i cleared dalvik cache....factory data...and 2-3 more options were there..and i cleared each and everything...i guess i cleared its OS too..!!...but then when i chose to reboot the device...there was a message saying your device is not rooted..."do u wish to root it"...i chose NO..!! n den it restarted saying no OS installed..!! n now when m trying to restart it...the sony logo comes up...den the black screen..!! i am not able to switch it off..!! until the battery is drained..!! pls help me..!! :'(

try flashing stock rom
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes