FORUMS

[Q] Root Failures with SAMSUNG NOTE 2 SGH-T889V (Canadian Wind carrier)

1 posts
Thanks Meter: 0
 
By ClaudiaCati, Junior Member on 9th July 2015, 04:19 PM
Post Reply Subscribe to Thread Email Thread
I have been trying for the past two days to root a Note 2 SGH-T889V running on Android 4.4.2 and keep failing miserably. Damn phone just wont root. On a few softwares I even got the message "Your phone is to strong to root" What the hell does that mean ? What is it . . . Fort Knox ?
What I've tried so far:
- Kingo Root (PC & Apk)
- KingRoot (PC & Apk)
- Framaroot
- iRoot (PC)
- Root Genius (PC)
- Wondershare MobileGo (PC)
- CF Auto Root throuh ODIN
- Root Master (Apk)
- SRS (PC)

Absolutely nothing worked. What gives ?
Can somebody make some suggestion or offer some insights on what could be wrong ? I followed every indication, every step to the letter on each method.
I am not very tech savy but I did manage to root my own Nexus 5 in no time with no hassles and without trying out so many methods. So what's the problem with the Samsung phone ?

Thank you for any responses.
Last edited by ClaudiaCati; 9th July 2015 at 04:27 PM.
 
 
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes