Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,893 Members 42,450 Now Online
XDA Developers Android and Mobile Development Forum

Persistent ABD problems with HTC One

Tip us?
 
devinchellberg
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Jul 2014
Default Persistent ABD problems with HTC One

Hello!

I have an HTC m7, and am using Windows 7 to interface with it. Long story short, I have twrp on it, but no working operating system. For a moment yesterday, it appeared successfully in the results of /adb devices, though when I tried to push a new rom to the internal storage on the phone using adb sideload, it failed (made it to 100% but then said failed, and when I tried to install the created .zip file, it failed as well). Since that attempt, I have been unable to see my phone as an ADB device again - I've reinstalled HTC drivers, tried various usb cables, and gone through many iterations of /adb devices (blank) /adb kill-server. After failing to find a solution elsewhere on these forums or elsewhere, I come to you.

I'd love to know if there's anything that could cause the phone to disappear after it had been previously connected, and if there's some further steps I could take to get it to work!

Thanks for your help,
Devin
 
KJ
Old
#2  
KJ's Avatar
Recognized Contributor
Thanks Meter 3244
Posts: 7,859
Join Date: May 2011
Location: The boonies - southwest Ontario
Hi there!

I suggest you try returning to stock, since you're having troubles with adb. Tho, it must be a driver issue, or cable, or USB port. Usually it ends up being the cable in cases similar to yours.

Anyway, if you have no luck, try returning to stock....here's a great guide,

>*HTC One*>*One General*>*[GUIDE] How to Return to 100% Stock

Of course you will need to install recovery and root again after.

Any questions on this can be asked in the guide thread.

Good luck!!
Sent from my new HTC One M8, N7, Moto X, GTab3 or S2.

Need help with poor battery life on the N5...or any device really? Lots of info in first 4 posts! >>>>
[Battery Life Help] Troubleshoot Battery Issues Here....and Tips

The Following User Says Thank You to KJ For This Useful Post: [ Click to Expand ]
THREAD CLOSED
Subscribe
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes