5,604,219 Members 48,932 Now Online
XDA Developers Android and Mobile Development Forum

Do cases block your radio or antenna?

Tip us?
 
dicecuber
Old
#1  
Account currently disabled - OP
Thanks Meter 51
Posts: 521
Join Date: Aug 2013
Location: Vancouver
Default Do cases block your radio or antenna?

Been frustrated this ever since I had this phone cased in a spigen ultra fit . It always drops signal. Used stock everything with original 4.4 to stock everything with 4.4.1 to 4.41 with 4.4 radio and every combination used still drops signal for me.

I've been running no case for the last 12hrs and no drops. Could this case be the culprit?

Sent from **Nexus 5 sucks**
 
Wbroshea
Old
#2  
Member
Thanks Meter 5
Posts: 72
Join Date: Apr 2010
Quote:
Originally Posted by dicecuber View Post
Been frustrated this ever since I had this phone cased in a spigen ultra fit . It always drops signal. Used stock everything with original 4.4 to stock everything with 4.4.1 to 4.41 with 4.4 radio and every combination used still drops signal for me.

I've been running no case for the last 12hrs and no drops. Could this case be the culprit?

Sent from **Nexus 5 sucks**
I hate to say it, and I still am not sure I believe it, but I have noticed very weak signal with my spigen slim armor on and better signal with it off. Probably just placebo as Im not sure how plastic would block signal, but it seems odd.
 
ThugEsquire
Old
#3  
ThugEsquire's Avatar
Senior Member
Thanks Meter 33
Posts: 165
Join Date: Jun 2010
To answer your questions:
  1. Yes, a case can absolutely interfere with the RF of your phone. However, plastic does not normally do this.
  2. If you are noticing better signal with the case off, and that is the only difference between readings of RSSI, then it's likely the case.
 
dicecuber
Old
#4  
Account currently disabled - OP
Thanks Meter 51
Posts: 521
Join Date: Aug 2013
Location: Vancouver
Thanks for your replies. I'll report back my findings after going caseless tonight

Sent from **Nexus 5 sucks**
 
kamnikaz
Old
#5  
kamnikaz's Avatar
Member
Thanks Meter 14
Posts: 65
Join Date: Jan 2011
Quote:
Originally Posted by Wbroshea View Post
I hate to say it, and I still am not sure I believe it, but I have noticed very weak signal with my spigen slim armor on and better signal with it off. Probably just placebo as Im not sure how plastic would block signal, but it seems odd.
I've noticed the same with my slimarmor

Envoyé de mon Nexus 5 en utilisant Tapatalk
Google Nexus 5 stock rooted / Franco kernel

 
bblzd
Old
#6  
Senior Member
Thanks Meter 178
Posts: 830
Join Date: Nov 2013
Location: Toronto
I've seen no loss of signal using a Ringke Fusion case.
W32
 
kpjimmy
Old
#7  
kpjimmy's Avatar
Senior Member
Thanks Meter 953
Posts: 4,490
Join Date: Jan 2009
Location: San Antonio TX
Quote:
Originally Posted by bblzd View Post
I've seen no loss of signal using a Ringke Fusion case.
No drops with my Spigen Ultra Hybrid or i-Blason Candygel hybrid tpu.
gplus.to/kpjimmy <---Add me to G+!
http://mycolorscreen.com/kpjimmy/<---My colorscreen images
 
PsychDrummer
Old
#8  
Senior Member
Thanks Meter 48
Posts: 301
Join Date: Nov 2012
There's a lot of complaints about weaker radio signal in 4.4.1. I use a slim armor and it doesn't seem like it affects it. I have pretty crappy reception at home though so who knows.
 
dicecuber
Old
#9  
Account currently disabled - OP
Thanks Meter 51
Posts: 521
Join Date: Aug 2013
Location: Vancouver
Hmmm no dropped signal today when I went caseless. But at the same time didn't have any calls longer than 2 minutes. So couldn't accurately test.

Sent from **Nexus 5 signal sucks**
 
droid_<3er
Old
#10  
droid_<3er's Avatar
Senior Member
Thanks Meter 86
Posts: 378
Join Date: Dec 2011
Location: Vancouver
Did you all take the OTA?

I'm on KANGAKAT 4.4.1 (I do believe that he didn't put the new radio in so it's still 4.4 radio) and reception is stellar. You could try fastboot flash radio with the original 4.4 radio.

PS: oh hey fellow vancouverite. All the other Canadians I've seen on here are from Toronto.
Phone: Nexus 5 32GB | Epsilon Project v7.1 | stock kernel | TWRP 2.6.3.4

My Rig: NZXT H440 | Xeon E3-1230V2 @ 3.5 GHz | Z77 Extreme3 | NH-U9B | 8GB DDR3-1600 C11 | GT 640 OEM GDDR5 | 240GB SSD 530 | XFX TS550 | Win 8.1 Pro | Samsung T240HD

Before you post about a question that's been answered one million times just because you feel that people of XDA are responsible for fixing your phone, please take the time to read this post.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...