Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,247 Members 47,758 Now Online
XDA Developers Android and Mobile Development Forum

Slow Download Speeds on T-Mobile

Tip us?
 
zoddfrank
Old
(Last edited by zoddfrank; 13th November 2013 at 12:34 PM.)
#1  
Member - OP
Thanks Meter 8
Posts: 51
Join Date: Sep 2010
Exclamation Slow Download Speeds on T-Mobile

*** Caution***

I may have found a bug in the 4.4 software... I am not 100% sure, but it has T-Mobile perplexed beyond belief!
So, here is the issue. Without being on Wifi try downloading any file from the app store or any large file in general that is 100MBs and up.

From what I have noticed, my HSPA+ Speeds and LTE speeds are insane. Insane enough that I can stream Netflix in HD like its nothing - Over the phone.

So, in a way that makes things look even more weird. --- Here is the issue at hand, whenever I try to download a file that is over 100MBs or more the download will start out fast
and after a few minutes of download slow down ( basically get totally reduced to Throttling-Like speeds.)-- Same case with the tethering too! ( I tested this) This does not make sense, --- Comedy Here. http://youtu.be/6Xywqv1cDH8

So, I called up T-Mobile and they tried very hard to help me... it was actually insane because the customer service was so damn good. I got all the way up to American Tech Rep... guess it was that interesting, the guy reset my connection to my phone while we ran multiple speed tests. --- End result was that he could not figure out what the hell it was, and since NEXUS 5s are so new they don't know a lot about them. The tech had to send a trouble ticket to google or what not and I won't hear from the tech for 3 days.

It doesn't make much sense because I just got on their network like on the 9th... only used less than 3 GBs... -_- and IF they throttle its after 5GBs.

So if you are with T-Mobile or with a company in America and NOT on a Grandfathered plan post a quick result or kinda verify that your unit is or is not performing the same way. This is a very annoying issue.

ALSO, I am on the Unlimited verified Post-Paid plan too... so monthly and this is supposed to give cell tower priority.. or something.

If anyone has a way for me to fix this or is having similar issues let me know!
The Following 4 Users Say Thank You to zoddfrank For This Useful Post: [ Click to Expand ]
 
ricostuart
Old
#2  
Senior Member
Thanks Meter 4
Posts: 226
Join Date: Aug 2009
I'm having similar problems on giffgaff (o2) in the UK.

Sent from my Nexus 5 using Tapatalk
 
zoddfrank
Old
#3  
Member - OP
Thanks Meter 8
Posts: 51
Join Date: Sep 2010
Quote:
Originally Posted by ricostuart View Post
I'm having similar problems on giffgaff (o2) in the UK.

Sent from my Nexus 5 using Tapatalk

Oh crap... so this isn't isolated... -_-
 
zoddfrank
Old
#4  
Member - OP
Thanks Meter 8
Posts: 51
Join Date: Sep 2010
BUMP! Seriously I can't be the only one.
 
rican408
Old
#5  
Senior Member
Thanks Meter 40
Posts: 389
Join Date: Jun 2010
I am getting the same great speeds that I got on 2 other phones. And I use about 5-8 gigs a month without any throttling. On T-Mobile.
 
FuMMoD
Old
(Last edited by FuMMoD; 13th November 2013 at 03:02 PM.)
#6  
FuMMoD's Avatar
Recognized Contributor
Thanks Meter 2,223
Posts: 4,516
Join Date: Mar 2009
Location: South Florida

 
DONATE TO ME


Running off Tmobile LTE on Metro PCS. Not me but same phone and location as myself.
 
zoddfrank
Old
#7  
Member - OP
Thanks Meter 8
Posts: 51
Join Date: Sep 2010
Quote:
Originally Posted by FuMMoD View Post


Running off Tmobile LTE on Metro PCS. Not me but same phone and location as myself.
I ran these tests, but that won't help you unless you really pay attention and watch your download slow down.

You need to try downloading an app or any file above 100 MB and see if it totally slows down within the first few minutes.

Mine does this ALL the time.. Meaning, It won't do that if I am on Wifi.

As stated, I stared my service on the 9th of this month... so its Bull DOO DOO!
 
zoddfrank
Old
#8  
Member - OP
Thanks Meter 8
Posts: 51
Join Date: Sep 2010
Can anyone on T-Mobile confirm what their APN is set on ??
 
frigidazzi
Old
#9  
Senior Member
Thanks Meter 78
Posts: 728
Join Date: Apr 2011
Quote:
Originally Posted by zoddfrank View Post
Can anyone on T-Mobile confirm what their APN is set on ??
I've had this problem with tmobile ever since I used the LTE hack on my N4 well over 6 months a go. I noticed it when i was on the APN with fast in it. The old HSPA+ one I was using before the LTE APN didn't have these problems. I know this doesn't help, but I've just accepted it as working as intended.
 
Synyster06Gates
Old
#10  
Synyster06Gates's Avatar
Senior Member
Thanks Meter 99
Posts: 463
Join Date: Jan 2011
Location: Leander, Texas
Name : T-Mobile LTE

APN: fast.tmobile.com

MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

MMS Protocol: WAP 2.0

MCC: 310

MNC: 260

APN Type: default,supl,admin,dun,mms
Nexus 5 - AICP
T-Mobile GS3 T999L - Dandroid - GONE
ATT GS3 i-747 - Intergalactic 3.0 - GONE
HTC Inspire 4G - many different ROMs - GONE

The Following 3 Users Say Thank You to Synyster06Gates For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes