5,597,261 Members 40,253 Now Online
XDA Developers Android and Mobile Development Forum

[How To For Sprint] fix persistent new voicemail notification! Need Root access.

Tip us?
 
PaulB007
Old
(Last edited by PaulB007; 9th December 2013 at 05:56 PM.)
#1  
Senior Member - OP
Thanks Meter 65
Posts: 574
Join Date: Dec 2008
Exclamation [How To For Sprint] fix persistent new voicemail notification! Need Root access.

Disclaimer: I am no developer, just someone who got sick of having to clear my phone data every hour or two to get rid of that stupid notification. I spent four hours last night deeply researching and looking at code to figure this out for myself and you guys as I know this is a major pain. I am proud to report back to you that after a day of resetting, and fully powering down my phone many times the notification has not came back. This took a TON of trial and error. I'm glad I can finally give something back to this community after all its provided me. I also do not claim to be the founder of this fix, although I feel I have certain variations of the fix that are my own. Whether or not my particular fixes are placebo or not I cannot say as I do not understand programming that well, but in my own testing they seemed to make the difference.

Side effects: None that I have noticed yet. Phone calls, texts, picture messages come through fine. I haven't had any problems. I am guessing if you change any of the setting in the phone app itself the settings may or may not be lost. That remains to be seen. You may need to re-apply the fix each time and likely with every new ROM flash. Let us know.

Let's get to it!


NOTE: I AM USING GOOGLE VOICE AND HAVE IT SET AS MY VOICEMAIL. DO NOT KNOW IF THIS MATTERS OR NOT.


Step 1: You will need to be rooted. Reboot to make sure you have the new voicemail notification.

Step 2: I will be using FX Explorer for this process. You will need to download the FX root add-on from the play store as well. If you have another root explorer and can figure out what I am saying that's fine.

Step 3: Open FX Explorer. Under the "Files" section tap "System (Root)" you'll likely get a warning dialog of some sort or su will ask for permissions. Grant them and accept the disclaimer warning if applicable.

Step 4: Next tap on the "data" folder. Within it, there will be another data folder. Tap the proceeding "data" folder.

Step 5: locate and tap the "com.android.phone" folder. Within it, tap on the "shared_prefs" folder. You should see a file called "com.android.phone_preferences.xml" you will want to long press on that file. You will tap "open with" after that you tap "Text Editor"

Step 6: fully replace the text within this file with the following:
Quote:
<?xml version='1.0' encoding='utf-8' standalone='yes' ?>
<map>
<string name="vm_number_key_cdma">##########</string>
<int name="vm_count_key_cdma" value="0" />
<boolean name="button_voicemail_notification_vibrate_key" value="false" />
</map>

IMPORTANT: THE ########## WILL BE YOUR 10 DIGIT PHONE NUMBER. REPLACE THOSE WITH YOUR PHONE NUMBER.

Step 7: Tap "File" up on the upper left corner and then tap "Save" after this, press your back button so you are back in the folder where you can see this file.

I do not know if the rest of this tutorial is required to be followed starting at Step 8 but its what I did. You can do it if you want to follow exactly what I did to receive my results.

Step 8: Long press on "com.android.phone_preferences.xml" and tap "Copy" tap your back button so that you are just outside of the "shared_prefs" folder and then tap the clipboard in the upper right corner. It will bring up a prompt to which you will press "Paste." long press the pasted "com.android.phone_preferences.xml" file and tap rename. Rename the file to "com.android.phone_preferences.xml.bak"

Step 9: Long press on your newly named "com.android.phone_preferences.xml.bak" and tap "copy." Go back into the "shared_prefs" folder and tap the clipboard up in the top right corner. Tap "paste" again. You should see your "com.android.phone_preferences.xml" and "com.android.phone_preferences.xml.bak" files together.

Step 10: Long press the "com.android.phone_preferences.xml" and tap "Permissions." Ensure that the permissions say "0660" or that you tap "read" and "write" only under the "Owner: radio" and "Group: radio" fields. Make sure there is nothing in the "Exec" field has permissions.

Step 11: go into your notifications on the top of your screen and long press on the voicemail notification. Tap "App Info." Force stop your phone application so that the notification disappears up top. Reboot or shut down your phone a few times. You should no longer see the notification anymore.

Step 12: Enjoy not seeing this annoying little **** of a notification again!


BAM BAM POW POW SHOOTER!!
The Following 5 Users Say Thank You to PaulB007 For This Useful Post: [ Click to Expand ]
 
PaulB007
Old
#2  
Senior Member - OP
Thanks Meter 65
Posts: 574
Join Date: Dec 2008
Ugh can a moderator please move this to Nexus 5 General please?


BAM BAM POW POW SHOOTER!!
The Following User Says Thank You to PaulB007 For This Useful Post: [ Click to Expand ]
 
troyhough
Old
#3  
Member
Thanks Meter 6
Posts: 67
Join Date: Jul 2008
i very much appreciate you finding this fix and posting it.

i had this exact problem with a Nexus 5 of mine this weekend. what i did to fix it was get on sprint's online chat and had them fully disable sprint voicemail. i use GV so i don't care if sprint provide's VM or not. after they disable VM, i went in and did a force stop / clear data on the phone/voice messaging app. this clears the notification. rebooted phone and as of 24 hours now, the notification has not returned.



Quote:
Originally Posted by PaulB007 View Post
Disclaimer: I am no developer, just someone who got sick of having to clear my phone data every hour or two to get rid of that stupid notification. I spent four hours last night deeply researching and looking at code to figure this out for myself and you guys as I know this is a major pain. I am proud to report back to you that after a day of resetting, and fully powering down my phone many times the notification has not came back. This took a TON of trial and error. I'm glad I can finally give something back to this community after all its provided me. I also do not claim to be the founder of this fix, although I feel I have certain variations of the fix that are my own. Whether or not my particular fixes are placebo or not I cannot say as I do not understand programming that well, but in my own testing they seemed to make the difference.

Side effects: None that I have noticed yet. Phone calls, texts, picture messages come through fine. I haven't had any problems. I am guessing if you change any of the setting in the phone app itself the settings may or may not be lost. That remains to be seen. You may need to re-apply the fix each time and likely with every new ROM flash. Let us know.

Let's get to it!


NOTE: I AM USING GOOGLE VOICE AND HAVE IT SET AS MY VOICEMAIL. DO NOT KNOW IF THIS MATTERS OR NOT.


Step 1: You will need to be rooted. Reboot to make sure you have the new voicemail notification.

Step 2: I will be using FX Explorer for this process. You will need to download the FX root add-on from the play store as well. If you have another root explorer and can figure out what I am saying that's fine.

Step 3: Open FX Explorer. Under the "Files" section tap "System (Root)" you'll likely get a warning dialog of some sort or su will ask for permissions. Grant them and accept the disclaimer warning if applicable.

Step 4: Next tap on the "data" folder. Within it, there will be another data folder. Tap the proceeding "data" folder.

Step 5: locate and tap the "com.android.phone" folder. Within it, tap on the "shared_prefs" folder. You should see a file called "com.android.phone_preferences.xml" you will want to long press on that file. You will tap "open with" after that you tap "Text Editor"

Step 6: fully replace the text within this file with the following:


IMPORTANT: THE ########## WILL BE YOUR 10 DIGIT PHONE NUMBER. REPLACE THOSE WITH YOUR PHONE NUMBER.

Step 7: Tap "File" up on the upper left corner and then tap "Save" after this, press your back button so you are back in the folder where you can see this file.

I do not know if the rest of this tutorial is required to be followed starting at Step 8 but its what I did. You can do it if you want to follow exactly what I did to receive my results.

Step 8: Long press on "com.android.phone_preferences.xml" and tap "Copy" tap your back button so that you are just outside of the "shared_prefs" folder and then tap the clipboard in the upper right corner. It will bring up a prompt to which you will press "Paste." long press the pasted "com.android.phone_preferences.xml" file and tap rename. Rename the file to "com.android.phone_preferences.xml.bak"

Step 9: Long press on your newly named "com.android.phone_preferences.xml.bak" and tap "copy." Go back into the "shared_prefs" folder and tap the clipboard up in the top right corner. Tap "paste" again. You should see your "com.android.phone_preferences.xml" and "com.android.phone_preferences.xml.bak" files together.

Step 10: Long press the "com.android.phone_preferences.xml" and tap "Permissions." Ensure that the permissions say "0660" or that you tap "read" and "write" only under the "Owner: radio" and "Group: radio" fields. Make sure there is nothing in the "Exec" field has permissions.

Step 11: go into your notifications on the top of your screen and long press on the voicemail notification. Tap "App Info." Force stop your phone application so that the notification disappears up top. Reboot or shut down your phone a few times. You should no longer see the notification anymore.

Step 12: Enjoy not seeing this annoying little **** of a notification again!
 
HaveAnEpiphany
Old
#4  
Junior Member
Thanks Meter 5
Posts: 19
Join Date: Sep 2010
Location: Sarasota, FL

 
DONATE TO ME
Thanks for this, PaulB007!

I have a Samsung Galaxy S III on Sprint, so mine turned out a little differently... but I used the info you posted here and wrote up the process for that device here.

Thanks again!
 
PaulB007
Old
#5  
Senior Member - OP
Thanks Meter 65
Posts: 574
Join Date: Dec 2008
This method may or may not work depending on your ROM, I have had mixed results after further testing..


BAM BAM POW POW SHOOTER!!
 
PaulB007
Old
#6  
Senior Member - OP
Thanks Meter 65
Posts: 574
Join Date: Dec 2008
Quote:
Originally Posted by PaulB007 View Post
This method may or may not work depending on your ROM, I have had mixed results after further testing..
Update: it seems that the "<string name="vm_number_key_cdma">##########</string>" is important to always have in the file mentioned in the OP. Without it the fix likely just won't work.


BAM BAM POW POW SHOOTER!!
 
bhake
Old
#7  
Senior Member
Thanks Meter 58
Posts: 242
Join Date: Nov 2009
Location: Houston
Just thought I'd throw this out there. I cleared the reoccurring icon by disabling "voicemail display" in Google voice app settings. The app is really outdated (long time GV user here) and IMO, I think it's a compatibility issue with the app. Once you uncheck "voicemail display" option, you won't see voicemails in your call log, but you can still see, read, and get a GV notification of your voicemail through the GV app.

Sent from my Nexus 5 using Tapatalk

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes