5,594,564 Members 32,464 Now Online
XDA Developers Android and Mobile Development Forum

[HOWTO][GUIDE] Repairing corrupted /data partition

Tip us?
 
kamilmirza
Old
(Last edited by kamilmirza; 14th March 2014 at 10:32 PM.)
#41  
kamilmirza's Avatar
Senior Member
Thanks Meter 241
Posts: 1,032
Join Date: Dec 2011
Location: Lahore
hello guys
i bought hammerhead today, i only used it for 10 mins :'(
unlocked the device and flashed twrp (no toolkits used) and was about to take backup
and then faced "unable to mount", tried all recoveries
and i can't boot into my stock ROM, the boot animation keeps on going and i can see the brightness increases but stay in boot animation
and sadly i have no warranty
i am downloading factory image and will report back
is there any method to re-partition data/storage partition? like THIS on HTC One

EDIT: well finally it's resolved by flashing factory image
hit the THANKS button if helped
Google Nexus 5
 
Datsun.510
Old
(Last edited by Datsun.510; 23rd March 2014 at 07:46 PM.)
#42  
Datsun.510's Avatar
Senior Member
Thanks Meter 1314
Posts: 583
Join Date: May 2009
Location: Las Vegas

 
DONATE TO ME
About my problem.

Installed a ROM using MultiRom. After trying the new ROM out and rebooting my device to boot my internal ROM, my device was stuck in a bootloop at the bootanimation. I restarted the device again and it went into recovery by itself, restarted it again with and same result. My SD Card was empty in the Recovery. I tried to ADB Push a new ROM to Recovery and then reinstalling the ROM but it said "Unable to mount Data". Tried to flash TWRP through fastboot and was successful but was not able get the phone booted, as it went straight to the Recovery again.

I started doing research to see how I could fix this issue and I was lucky enough to run across this thread.

This line.... saved my phone.

Enter: ‘e2fsck /dev/block/platform/msm_sdcc.1/by-name/userdata’

After running this line and hitting 'yes' about 40 times, I rebooted my recovery once it finished. Now my SD Card was showing up again. I tried booting the ROM and it wouldn't work. So I dirty flashed my ROM and then it booted successfully.

I have now backed up my phone and will wipe it completely to make sure there are no more errors in the partitions.

Thank you so much for this information.
CURRENT DEVICES:
Nexus 5 32GB
PREVIOUS DEVICES:
Nexus 4 16GB
Nexus 7 Tablet
Samsung Galaxy S2 (T989)
HTC Amaze
HTC Sensation 4G
HTC HD2
HTC Touch Pro 2
HTC Fuze
HTC Tilt
HTC Mogul
 
trschober
Old
#43  
Member
Thanks Meter 9
Posts: 44
Join Date: Jul 2010
Location: Santiago
As a long time linux admin, I knew my data partition was corrupted the minute my phone started force closing, and I knew i made it worse when I force rebooted.
This little trick to run e2fsck from recovery saved the day! thanks!
 
wrick17
Old
#44  
wrick17's Avatar
Senior Member
Thanks Meter 54
Posts: 200
Join Date: Sep 2012
Location: Kolkata
U literally saved my life dude!! Thanks
Tags
/data error, /sdcard error, corrupted data partition, format data error, format sdcard error
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes