Post Reply

[Tutorial] Missed Calls Workaround

OP yoyo81

1st July 2014, 07:34 PM   |  #1  
OP Junior Member
Thanks Meter: 6
 
25 posts
Join Date:Joined: May 2010
I've been experiencing the problem of my Nexus 5 not receiving phone calls while on LTE and Wifi. This issue is documented in the following places:

http://www.androidpolice.com/2014/02...ages-for-some/
http://productforums.google.com/d/to...us/eOToYgJXdrw
http://forums.androidcentral.com/goo...yone-else.html
http://forum.xda-developers.com/goog...calls-t2528602

I don't know what the root cause is, but 4.4.4 still has not addressed this issue. I have found a work around, and thought it might help others experiencing the same issue. This is NOT the same as the eCSFB problem described elsewhere (I'm in the NY metro area with all the towers upgraded)

My original fix was to manually turn the Mobile Network to CDMA when on Wifi, then manually change it back to LTE when away from the hotspot. This seems to have increased the reliability of receiving phone calls. However, if I forgot, I'll miss calls again.

The Workaround (special thanks to @veagles and @nuts77 for their posts)

Requirements:
1. Tasker (well worth the 2.99 from the Play store, free trial available)
2. xPosed framework http://forum.xda-developers.com/xpos...3/post24267797
3. intelli3g http://forum.xda-developers.com/nexu...ttery-t2580234

Steps:
1. Install xPosed framework and intelli3g (make sure to enable intelli3g)
2. Reboot? (just to be safe)
3. Install Tasker
4. Create a profile for this workaround
  • Click +
  • Click State
  • Click Net
  • Click Wifi Connected
5. Add New Task to Profile (We'll call this one 3G)
6. Add Action to 3G Task
  • Click +
  • Click Misc
  • Click Send Intent
7. Configure the Action
  • Action should read: action.intelli3g.CHANGE_NETWORK_TYPE
  • Extra should read: extra.intelli3g.NETWORK_TYPE:<3G NETWORK TYPE>
  • Click Send Intent

The <CDMA NETWORK TYPE> should be replaced with an integer value from the following table, depending on your network. (I'm on Sprint, and used 4)

0: 3G GSM Preferred (I think?)
1: 2G GSM
2: 3G GSM
3: 3G/2G GSM auto (PRL)
4: 3G/2G CDMA auto (PRL)
5: 2G CDMA
6: 3G CDMA
7: GSM/CDMA auto (PRL)
8: LTE/CDMA auto (PRL)
9: LTE/GSM auto (PRL)
10: LTE/GSM/CDMA auto (PRL)
11: LTE only

You can test this configuration by turning on Wifi, and seeing that your Network is now on 3G.

For the Reverse, you simply create an Exit task/action on the Wifi profile above.

1. Add New Task to Profile, as Exit Task (I called it LTE) <- this is for when you leave Wifi
2. Add Action to LTE Task
  • Click +
  • Click Misc
  • Click Send Intent
3. Configure the Action
  • Action should read: action.intelli3g.CHANGE_NETWORK_TYPE
  • Extra should read: extra.intelli3g.NETWORK_TYPE:<LTE NETWORK TYPE>
  • Click Send Intent

Again, since I'm on a CDMA network, I chose 8 LTE/CDMA for my NETWORK_TYPE.

After doing this, and testing, it seems I'm receiving calls again when on Wifi. Hope this helps someone else!
Last edited by yoyo81; 1st July 2014 at 07:37 PM. Reason: Misnumbered some steps
The Following 3 Users Say Thank You to yoyo81 For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Nexus 5 General by ThreadRank