Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,291 Members 47,485 Now Online
XDA Developers Android and Mobile Development Forum

[Q] 2-3 second bluetooth audio lag/delay

Tip us?
 
cnstarz
Old
#1  
Senior Member - OP
Thanks Meter 597
Posts: 1,391
Join Date: Feb 2010
Default [Q] 2-3 second bluetooth audio lag/delay

Does anyone else experience bluetooth audio lag or delay? When my n5 is paired to my car (2010 Mazda 3), my music doesn't play through my speakers until about 3 seconds later. Audio for movies and videos and games are the same way, so they're out of sync. If I run the Audio Router app (forces audio to be played thru mono "headset mode" [not sure if that's what that's called]) then the lag/delay disappears and everything is fine, except that the audio is now playing at the lower headset bitrate and is mono.


So far, my car is the only thing I have to pair my phone with so I don't know if it's the car or the phone. But, I've only experienced this problem on 4.4 roms. 4.2 was fine, no audio lag at all. Every single 4.4 rom I've used has this problem (cm, aokp, pa, slim, pac, and stock).

The only patch I can think of for movies is to find a player that can allow me to offset the audio (like VLC on Windows does), but I haven't found one that supports that.

Any ideas?
 
nigelhealy
Old
#2  
nigelhealy's Avatar
Senior Member
Thanks Meter 120
Posts: 544
Join Date: Aug 2012
Location: San Francisco
Quote:
Originally Posted by cnstarz View Post
Does anyone else experience bluetooth audio lag or delay? When my n5 is paired to my car (2010 Mazda 3), my music doesn't play through my speakers until about 3 seconds later. Audio for movies and videos and games are the same way, so they're out of sync. If I run the Audio Router app (forces audio to be played thru mono "headset mode" [not sure if that's what that's called]) then the lag/delay disappears and everything is fine, except that the audio is now playing at the lower headset bitrate and is mono.


So far, my car is the only thing I have to pair my phone with so I don't know if it's the car or the phone. But, I've only experienced this problem on 4.4 roms. 4.2 was fine, no audio lag at all. Every single 4.4 rom I've used has this problem (cm, aokp, pa, slim, pac, and stock).

The only patch I can think of for movies is to find a player that can allow me to offset the audio (like VLC on Windows does), but I haven't found one that supports that.

Any ideas?
It is an issue with the link to your car. I get the same thing between all my Android devices and one particular Bluetooth device, my context is different using Chromecast to see on TV the picture but hear on bluetooth off my handset the audio, I've tried N4, N7 2012, N7 2013, N10. The only fix in my context is HDMI off the N10 (so in N5 it would be Slimport) and bluetooth off the handset.

For your car, does it have a Tape casette player old tech? They used to have an audio-male to casette adaptors, or an audio socket at all, then just male-male cable to the N5?
Nexus 5 stock 4.4.4 +ElementalX rooted, Nexus 7 2013 stock 4.4.4 +ElementalX rooed, Nexus 10 CM 11 rooted, OnePlusOne stock rooted.
Tags
audio, bluetooth, delay, lag
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes