Would The LG G4 Fare Well With The Snapdragon 808?

The LG G4 has a lot to prove, given that last year’s LG G3 was among the best … more

CyanogenMod 12.1 for Android One

Android One devices once again got a pretty stable release of Android 5.1. XDA Recognized … more

DexPatcher: Patch Android APKs Using Java

You’ve probably seen or installed modified applications, be it a patched dialer for your … more

Is Cloud Storage Ready to Replace External Storage?

With more and more OEMs ditching SD cards on their flagships, cloud storage is … more
Post Reply Subscribe to Thread Email Thread

can access phone in PTP but not MTP

6th January 2014, 07:01 AM |#1  
OP Senior Member
Thanks Meter: 6
 
159 posts
Join Date:Joined: Dec 2012
hey guys
not really sure what the hell is wrong

i finished rooting an unlocking my pohne with WugFresh - and obviously doing the first driver steps means my drivers are functional.

when i connect my phone to my pc (win7) nothing comes up while its on MTP, first time i chose MTP it installed drivers but there is no popup window on my PC to choose an action, nor can i see the phones SD on my computer.
if i switch to camera mode (PTP) i instnatly get the Autoplay menu and can access two folders DCIM and Pictures.

i tried:
doing the initial installation (and uninstallation) of drivers in WUG a few times
turning MTP/PTP on off
turning usb debut on/off
plugging to another pc - WORKED INSTANTLY

so why wont my dumb PC be able to do this?
Last edited by Caniv; 6th January 2014 at 07:13 AM.
6th January 2014, 07:05 AM |#2  
Ajaykumar21066's Avatar
Senior Member
Flag PUNE
Thanks Meter: 72
 
296 posts
Join Date:Joined: Dec 2012
Donate to Me
More
Quote:
Originally Posted by Caniv

hey guys
not really sure what the hell is wrong

i finished rooting an unlocking my pohne with WugFresh - and obviously doing the first driver steps means my drivers are functional.

when i connect my phone to my pc (win7) nothing comes up while its on MTP, first time i chose MTP it installed drivers but there is no popup window on my PC to choose an action, nor can i see the phones SD on my computer.
if i switch to camera mode (PTP) i instnatly get the Autoplay menu and can access two folders DCIM and Pictures.

help!

i also did the first steps in WUG like 10 times.

Buddy , check if USB debugging mode is active
6th January 2014, 07:06 AM |#3  
OP Senior Member
Thanks Meter: 6
 
159 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by Ajaykumar21066

Buddy , check if USB debugging mode is active

sorry forgot to mention, its off, i even tried turning it on and off also MTP..
no dice.
6th January 2014, 07:14 AM |#4  
Ajaykumar21066's Avatar
Senior Member
Flag PUNE
Thanks Meter: 72
 
296 posts
Join Date:Joined: Dec 2012
Donate to Me
More
Keep it on an then try , may one restart will help but keep debugging on
6th January 2014, 07:22 AM |#5  
rootSU's Avatar
Senior Member
Flag Oxenhope, West Yorkshire, UK
Thanks Meter: 16,273
 
27,788 posts
Join Date:Joined: Aug 2010
More
Try manually uninstalling the drivers from device manager and reboot both phone and computer. Connect in ptp then switch to mtp

-----------------------
Sent via tapatalk.

I do NOT reply to support queries over PM. Please keep support queries to the Q&A section, so that others may benefit
6th January 2014, 07:23 AM |#6  
OP Senior Member
Thanks Meter: 6
 
159 posts
Join Date:Joined: Dec 2012
wow im not sure why but this did it:

connected to PC (AGAIN) with MTP and PTP and DEBUT off

turned on debug and removed driver from device manager
turned off debug

turned on MTP and removed driver
turned off MTP

turned on PTP and removed driver
turned off PTP

and then i activated to install drivers (and after install deactivated) in this order
PTP
MTP
DEBUG

now all is installed and working

no idea why.

ty!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes