Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,777,785 Members 46,720 Now Online
XDA Developers Android and Mobile Development Forum

android os wakelock.. only when connected to home wifi.

Tip us?
 
MarkGbe
Old
#1  
Senior Member - OP
Thanks Meter 37
Posts: 367
Join Date: Nov 2010
Location: Buffalo, NY
Default android os wakelock.. only when connected to home wifi.

i've had this issue since ive had my nexus 4 on 4.3 and now it continues with my nexus 5 on 4.4

When i'm connected to my home wifi, 'android OS' will show on my battery usage as the highest offender, causing the phone to stay awake 90% of the time. This doesn't happen when im at work on the wifi and also doesn't happen when on mobile data.

Any ideas on this? i'm been messing around with wifi settings but no luck. i have a router and a separate wifi access point at home. Could it be the router?

Thanks
 
abtekk
Old
#2  
abtekk's Avatar
Senior Member
Thanks Meter 291
Posts: 353
Join Date: Apr 2011
Location: London

 
DONATE TO ME
Quote:
Originally Posted by MarkGbe View Post
i've had this issue since ive had my nexus 4 on 4.3 and now it continues with my nexus 5 on 4.4

When i'm connected to my home wifi, 'android OS' will show on my battery usage as the highest offender, causing the phone to stay awake 90% of the time. This doesn't happen when im at work on the wifi and also doesn't happen when on mobile data.

Any ideas on this? i'm been messing around with wifi settings but no luck. i have a router and a separate wifi access point at home. Could it be the router?

Thanks
Easy fix: Don't connect to home wifi! *lulz*

No really though, tried other ROMs? Could possibly be the router if it doesn't happen to other connections. What router is it?
Google Nexus 5 - OmniRom

 
MarkGbe
Old
#3  
Senior Member - OP
Thanks Meter 37
Posts: 367
Join Date: Nov 2010
Location: Buffalo, NY
Quote:
Originally Posted by abtekk View Post
Easy fix: Don't connect to home wifi! *lulz*

No really though, tried other ROMs? Could possibly be the router if it doesn't happen to other connections. What router is it?
I have not tried roms, its bone stock unrooted. I have a linksys wrt54g router(tomato) and a tplink wa901nd access point(stock firmware , tried openwrt with the same wakelock issues)

I'm thinking i might have to eliminate the access point to see if the issues goes away or not, then maybe replace the router.
 
abtekk
Old
#4  
abtekk's Avatar
Senior Member
Thanks Meter 291
Posts: 353
Join Date: Apr 2011
Location: London

 
DONATE TO ME
Quote:
Originally Posted by MarkGbe View Post
I have not tried roms, its bone stock unrooted. I have a linksys wrt54g router(tomato) and a tplink wa901nd access point(stock firmware , tried openwrt with the same wakelock issues)

I'm thinking i might have to eliminate the access point to see if the issues goes away or not, then maybe replace the router.
Connect to them both individually, just see if the issue persists. Maybe the router is sending messages to Android?
Google Nexus 5 - OmniRom

 
MarkGbe
Old
#5  
Senior Member - OP
Thanks Meter 37
Posts: 367
Join Date: Nov 2010
Location: Buffalo, NY
Quote:
Originally Posted by abtekk View Post
Connect to them both individually, just see if the issue persists. Maybe the router is sending messages to Android?
thats what im thinking. it also affects my Nexus 7 2013. more testing!
 
abtekk
Old
#6  
abtekk's Avatar
Senior Member
Thanks Meter 291
Posts: 353
Join Date: Apr 2011
Location: London

 
DONATE TO ME
Quote:
Originally Posted by MarkGbe View Post
thats what im thinking. it also affects my Nexus 7 2013. more testing!
Keep me posted, we'll sort it!
Google Nexus 5 - OmniRom

 
littleemp
Old
#7  
Senior Member
Thanks Meter 48
Posts: 253
Join Date: May 2011
I think I'm getting this as well. If I'm connected to Wifi and leave my phone on standby it will drain 8-12% per hour, but if I leave it on mobile data it will drain only 0.5-1% per hour. I'm going to download BetterBatteryStats and see if I can find the process causing this.
 
alistairs1
Old
#8  
Senior Member
Thanks Meter 32
Posts: 102
Join Date: Oct 2012
Default wlan_rx_wake

A fairly common and problematic cause of this can be identified by wlan_rx_wake being the highest wakelock keeping the phone awake as seen in betterbatterystats or similar.

There is a great thread listing all the likely causes:

http://forum.xda-developers.com/show....php?t=2519294

But whether you can isolate which cause or whether you can do anything about it is another story. For me it eventually turned out to be traffic generated from Windows machine on my network, I followed the advice to Disable IPv6, IP Helper service, shell hardware detection service and the Windows Media Player Network Sharing Service on each Windows PC and my stay awake time from Android OS plummeted from hours to minutes which I can deal with.
Nexus 5 Stock Root / G Watch / Nexus 7 LTE Stock
 
MarkGbe
Old
#9  
Senior Member - OP
Thanks Meter 37
Posts: 367
Join Date: Nov 2010
Location: Buffalo, NY
I ended up assigning static IPs to both my nexus 7 and nexus 5 and the issue has been resolved.
 
Gregzi
Old
#10  
Gregzi's Avatar
Senior Member
Thanks Meter 67
Posts: 150
Join Date: Feb 2011
Default Confirmed!

Quote:
Originally Posted by MarkGbe View Post
I ended up assigning static IPs to both my nexus 7 and nexus 5 and the issue has been resolved.
I saw this on xda portal and I can tell, that problem is resolved when setting PI from DHCP to Static.
At home I have both gadgets connected with manual IP for quite some time
Ended up with great battery life on Mahdi rom (N5)...
Phone: Hammerhead
Baseband: M8974A
Rom: 4.4.3 - SOKP - RC4
Kernel: bundled with ROM
System is running on ext4
---------------------------------------------
Tablet: Galaxy Tab2 P5100
Baseband: XXDMG1
Rom: KK 4.4.3 - Omni
Kernel: 3.0.101...AGNi
System is running on F2FS

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes