5,600,335 Members 34,442 Now Online
XDA Developers Android and Mobile Development Forum

After applying root to 4.4.2 screen turns on by itself

Tip us?
 
pancomido
Old
#1  
Member - OP
Thanks Meter 2
Posts: 33
Join Date: Dec 2011
Default After applying root to 4.4.2 screen turns on by itself

So, I got the 4.4.2 OTA some days ago and just today I realised I had lost root. Also, I could not enter TWRP, so I flashed TWRP again and rooted the phone.

Everything went fine, but now the screens turns on by itself to show the lock screen every 3 or 4 minutes. I tried rebooting and then I tried wiping caches, but it's still the same.

Any ideas? Thanks!
 
Maxyman
Old
#2  
Maxyman's Avatar
Junior Member
Thanks Meter 15
Posts: 18
Join Date: Dec 2013
Location: Australia
Quote:
Originally Posted by pancomido View Post
So, I got the 4.4.2 OTA some days ago and just today I realised I had lost root. Also, I could not enter TWRP, so I flashed TWRP again and rooted the phone.

Everything went fine, but now the screens turns on by itself to show the lock screen every 3 or 4 minutes. I tried rebooting and then I tried wiping caches, but it's still the same.

Any ideas? Thanks!
It depends on a few factors, I think. 1) Do you have any apps that could induce a screen wake? 2) While rooted did you have any custom configs on your phone that is not part of the STOCK KitKat?

Look, my best solution especially since after an OTA while rooted is to do a factory reset and rerooting after that initial setup. I know that's not the most attractive option but if you can do it I would suggest to do it.

Oh oh, also, for some reason--and this is with FULL DISCLAIMER that I AM NOT RESPONSIBLE FOR ANY DATA LOSS YOU MAY INCUR or if your phone EXPLODES--but whenever I do a factory wipe from recovery (I use TWRP) I don't lose my personal data, such as photos and music, because it only wipes Data, Cache, and Dalvik--which only holds apps and stuff. From my understanding, libraries from Music and Photos are in the *SDCARD* folder which isn't deleted in the factory reset function. Anyhoo... I suggest to do a FULL BACKUP before attempting anything I'm totally not responsible for ANY LOSS OF DATA

Haha... See how that goes
Using Tapatalk
The Following User Says Thank You to Maxyman For This Useful Post: [ Click to Expand ]
 
chi_heng
Old
#3  
Junior Member
Thanks Meter 7
Posts: 21
Join Date: Sep 2013
check if you have forgotten to grant permission for apps that require roots to work (e.g. Greenify, betterbattery, etc). When they ask for permission for root access in the background they will switch on the screen. This odd behaviour should go away once you have grant them access.
The Following 2 Users Say Thank You to chi_heng For This Useful Post: [ Click to Expand ]
 
pancomido
Old
#4  
Member - OP
Thanks Meter 2
Posts: 33
Join Date: Dec 2011
Thanks, guys. I was just coming back to say that it is fixed. Good to know about the wipe not affecting the emulated sdcard, Maxy.

It was actually because of what chi_heng said, I think. After rooting many apps were supposed to get permissions but SU wouldn't show the dialogue. I rebooted again a few times and waited and then some of those dialogues came up.

Thanks!
 
P.Mobile
Old
#5  
P.Mobile's Avatar
Senior Member
Thanks Meter 934
Posts: 4,332
Join Date: Nov 2011
Location: RhOdE IsLAnD... 401
Quote:
Originally Posted by chi_heng View Post
check if you have forgotten to grant permission for apps that require roots to work (e.g. Greenify, betterbattery, etc). When they ask for permission for root access in the background they will switch on the screen. This odd behaviour should go away once you have grant them access.
yep.. u are right.. this was happening to me the other day but on my nexus 7..
Tags
4.4.2, screen turning on
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes