Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,829 Members 42,669 Now Online
XDA Developers Android and Mobile Development Forum

Wireless charging problem - a weird one

Tip us?
Member - OP
Thanks Meter 0
Posts: 39
Join Date: Dec 2010
Default Wireless charging problem - a weird one

Hey all.

I have a nexus 5 that refuses to charge wirelesslly in Kit Kat. I have 2 wireless chargers (not the google one) that work fine with my wife's Galaxy s4 (with the add on).

Every time I have tried my nexus 5 the lights flash from red to green over and over again. With these chargers the light is red when not charging and they turn green when charging a phone.

Anyway, here's the kicker. With the Android L preview it works fine. No issues. Went back to stock 4.4.4 and they no worky.

Any ideas?
Thanks Meter 9
Posts: 39
Join Date: Jan 2013
Have you tried a 4.4.4 custom rom?
I am using two qi-chargers (original nexus 5 at work and a noname-orb from ebay at home) and can't reproduce your error... Both are working flawlessly with either stock or latest cm-nightly.
all those who believe in telekinesis: raise my hand!
dave2metz's Avatar
Senior Member
Thanks Meter 174
Posts: 1,145
Join Date: Oct 2010
Location: Clearwater, Florida
Very strange. I have a cheap ass qi wireless charger that works flawlessly with any Rom. Hope you figure it out.

- NEXUS 5 -
Member - OP
Thanks Meter 0
Posts: 39
Join Date: Dec 2010
Agreed that it's super weird.

At first I thought my wireless was pooched but seeing it work with L made me wonder if there is another issue.

The chargers do recognize that something has been placed on them because the leds change for a second and then flash and the phone doesn't chime or indicate charging.

Also I can't use a custom rom because I need a stock rom to test work on for my client.
Junior Member
Thanks Meter 8
Posts: 13
Join Date: Aug 2011
I had this problem recently, probably out of different reasons. I removed my N5's back cover and did the GPS antenna fix (LINK if anyone needs it), and when I put it back the wireless charging didn't work. The charger kept flashing from green to red.

After some googling I found this:
I had the same issue before when I swapped the back on my N5. Try making sure the last clip is snapped in place the centre of the phone. It holds the contacts to the wireless coil.
Sorry if this doesn't help.
The Following User Says Thank You to RokRovan For This Useful Post: [ Click to Expand ]
Member - OP
Thanks Meter 0
Posts: 39
Join Date: Dec 2010
Fixed my problem. I installed multiboot to see if L would still work. My bootloader was locked so I had to wipe everything. Did a fresh 4.4.4 setup and then installed multirom and L.

Setup L and tested wireless charging. Works. Reboot into KitKat. Works.

No idea what happened before but it works now.

Thanks to all of you for the input.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes