Velocity is Like OpenTable on Steroids

We all enjoy a night out with friends or our significant other from time to time. However, there is … more

Android Lollipop Lands for the Sony Xperia Z Ultra

The undisputed king of the beasts–at least in Sony’s current stable,is the … more

Android 5.0 Lollipop in 3D–EVO 3D, That Is!

It is that time of the year once again. Flowers bloom (or snow falls, depending on which … more

Gaming Console with Lollipop? Ouya Gets an Android TV Port

Android is a very flexible platform, and it can be used on a large variety of … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Battery Drain

OP r7r8

10th February 2014, 06:39 PM   |  #1  
OP Member
Flag Mumbai
Thanks Meter: 2
 
43 posts
Join Date:Joined: May 2012
More
I have he Nexus 5 since the past 5 months now! I never faced any battery problem. Now since 3-4 days, i have terrible battery drain. I charge my phone to 100% and sleep and in 8-10hrs sleep, the battery is down to 50% . Android OS and Android system are using 30-35% each. I'm on stock and not rooted. What should I do?
10th February 2014, 06:50 PM   |  #2  
jd1639's Avatar
Recognized Contributor
Minnetonka, MN
Thanks Meter: 3,796
 
10,866 posts
Join Date:Joined: Sep 2012
Find out where you wake locks are. Get something like betterbatterystats.
The Following User Says Thank You to jd1639 For This Useful Post: [ View ]
10th February 2014, 07:24 PM   |  #3  
OP Member
Flag Mumbai
Thanks Meter: 2
 
43 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by jd1639

Find out where you wake locks are. Get something like betterbatterystats.

I did! It shows PowerManagerService as the main culprit. wlan_rx_wake and wlan_wd_wake aer also equally responsible. But i dont know what that means. Any suggestions?
10th February 2014, 07:38 PM   |  #4  
_MetalHead_'s Avatar
Senior Member
Flag Chicagoland
Thanks Meter: 2,437
 
5,801 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by r7r8

I did! It shows PowerManagerService as the main culprit. wlan_rx_wake and wlan_wd_wake aer also equally responsible. But i dont know what that means. Any suggestions?

It's likely your wifi. Did you recently switch to a different router? Some routers cause excessive wakelocks which in turn cause bad drain. If I leave my wifi on overnight I can sometimes lose 10-15%, if I leave wifi off I generally only lose 1-2% overnight.
10th February 2014, 07:52 PM   |  #5  
OP Member
Flag Mumbai
Thanks Meter: 2
 
43 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by _MetalHead_

It's likely your wifi. Did you recently switch to a different router? Some routers cause excessive wakelocks which in turn cause bad drain. If I leave my wifi on overnight I can sometimes lose 10-15%, if I leave wifi off I generally only lose 1-2% overnight.

Nope! i have been using the same router. Thinking of buying a new one though as this one is 2-3 yrs old!
Anything else I can do? Apart from changing my router?
10th February 2014, 08:00 PM   |  #6  
_MetalHead_'s Avatar
Senior Member
Flag Chicagoland
Thanks Meter: 2,437
 
5,801 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by r7r8

Nope! i have been using the same router. Thinking of buying a new one though as this one is 2-3 yrs old!
Anything else I can do? Apart from changing my router?

Try disabling wifi before you hit the sack tonight just to see if that is indeed the cause.
10th February 2014, 08:04 PM   |  #7  
OP Member
Flag Mumbai
Thanks Meter: 2
 
43 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by _MetalHead_

Try disabling wifi before you hit the sack tonight just to see if that is indeed the cause.

Ok cool! ill give it a try
10th February 2014, 10:56 PM   |  #8  
Senior Member
Flag Toronto
Thanks Meter: 353
 
1,458 posts
Join Date:Joined: Nov 2013
More
Quote:
Originally Posted by r7r8

Nope! i have been using the same router. Thinking of buying a new one though as this one is 2-3 yrs old!
Anything else I can do? Apart from changing my router?

Do you know if your wireless network is using 2.4Ghz or 5Ghz? Selecting one or the other and not using Automatic seems to fix speed issues and might also help with wake locks.

Otherwise you can try setting Locations to Device Only instead of Battery Saver and also disable Wifi always scanning if it's on.
11th February 2014, 05:58 AM   |  #9  
Member
Thanks Meter: 7
 
97 posts
Join Date:Joined: Jun 2007
why don't use both?

Sent from my Nexus 5 using xda app-developers app
12th February 2014, 04:52 AM   |  #10  
MrObvious's Avatar
Senior Member
Flag Wichita KS
Thanks Meter: 273
 
1,959 posts
Join Date:Joined: Mar 2008
More
Clear your cache. Sometimes weirdness can result from that.

Sent from my Nexus 5 using xda app-developers app

Post Reply Subscribe to Thread

Tags
battery drain, nexus 5 4.4.2
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes