Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,814,166 Members 45,477 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Battery Usage Incorrect

Tip us?
 
PsychDrummer
Old
#1  
Senior Member - OP
Thanks Meter 98
Posts: 647
Join Date: Nov 2012
Default [Q] Battery Usage Incorrect

Hi everyone, I was going to wait until tomorrow to post a question but something weird happened just now that changed the situation. I recently got a replacement, so I decided to root, run xposed and greenify. I was testing out the battery and it was doing fairly well. I got almost 2 days with 3 hours of SoT. This morning after unplugging I noticed Android System (or Android OS) was taking a significant chunk of %. However, it didn't seem as though my battery was draining a lot. I tried rebooting and charghing back upto 100% and it still kept happening. At times it was Android System and at other times it was Android OS.

I decided to download BBS since from reading the forums that seems to be a way to determine the culprit. At first BBS was showing a wake lock ratio of about 85% wake lock and 15% deep sleep. This was having the phone on for about an hour. It showed it being kept awake for about 40 min or so. The battery wasn't draining incredibly fast, but the stock battery history chart was showing that it was taking about 50% of the battery. I decided to just let it be and see how it does throughout the day so if it continues I can just post the log here. After a few hours it seemed to have gone away. While it was still showing that Android OS was taking about 30%, the wake lock/deep sleep was getting better where at this point after 10 hours it's about 6 hr 45 min of deep sleep, 3h 12m of wake lock with 1 hour and 2 min of SoT. The battery is at 71%. So, there doesn't seem to be an extreme drain. However, what was really strange was I was just looking though GravityBox settings (only added day to status bar clock, not sure if it was after that) and the battery usage just changed on the stock battery, and GSam, where Android OS is showing that it took 73% of the battery and even the screen which was on for an hour only took 6%.

Has anyone encountered this? I can post the log from the first hour and the log from now if anyone is willing to look at it. Thanks!

I'm rooted, with TWRP, xposed module with gravity box, greenify, and app oppsX. Those are my only mods.
 
simms22
Old
#2  
simms22's Avatar
Recognized Contributor
Thanks Meter 21,473
Posts: 25,856
Join Date: Jun 2009
Location: BROOKLYN!
derp. misread.
Google+ Profile
Twitter Simms22
DerKernel For Trinity kernels and more!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes