Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,290 Members 45,979 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Bootloop when power button sometimes pressed

Tip us?
 
ultimaflux
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Aug 2014
Unhappy [Q] Bootloop when power button sometimes pressed

Hi everyone!

I think my bootloop problem may be a unique one because it only occurs whenever I press the power button (and I've kinda searched other threads and couldn't find a bootloop issue like mine). But before I explain in depth, here are my specs:

Stock 4.4.4 rom
Rooted, with xposed + gb
ElementalX 1.00 kernel

This problem is a randomly occurring one; when my phone is fine and I press the power button, it almost usually goes into a bootloop. It can either stay on the google screen or last all the way up to the x-boot one. Sometimes from the x-boot screen, it'll reboot again. So I realized that if I randomly press the power button a few times (usually trial and error), the problem goes away sometimes and I boot normally again. However, if I hit the power button again for any reason, the bootloop issue relapses.

Also another thing to note is sometimes when my phone is switched on and operating normally and I press the button, it doesn't always reboot immediately. Sometimes it behaves as if the power button is held down and the power menu pops up in the lockscreen... then subsequently it boot loops.

So I'm not sure if this is a hardware issue to do with the button itself (because I very rarely ever drop my phone. Perhaps about 3 times in the past 8-9 months since Dec 2013?) or it's a software issue...which will mean I've to reflash my stock rom.

Anyone with a similar issue please help! It's kinda driving me nuts cos I can't even unlock my phone without triggering a bootloop...
 
kisetsu17
Old
#2  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Dec 2011
Quote:
Originally Posted by ultimaflux View Post
Hi everyone!

I think my bootloop problem may be a unique one because it only occurs whenever I press the power button (and I've kinda searched other threads and couldn't find a bootloop issue like mine). But before I explain in depth, here are my specs:

Stock 4.4.4 rom
Rooted, with xposed + gb
ElementalX 1.00 kernel

This problem is a randomly occurring one; when my phone is fine and I press the power button, it almost usually goes into a bootloop. It can either stay on the google screen or last all the way up to the x-boot one. Sometimes from the x-boot screen, it'll reboot again. So I realized that if I randomly press the power button a few times (usually trial and error), the problem goes away sometimes and I boot normally again. However, if I hit the power button again for any reason, the bootloop issue relapses.

Also another thing to note is sometimes when my phone is switched on and operating normally and I press the button, it doesn't always reboot immediately. Sometimes it behaves as if the power button is held down and the power menu pops up in the lockscreen... then subsequently it boot loops.

So I'm not sure if this is a hardware issue to do with the button itself (because I very rarely ever drop my phone. Perhaps about 3 times in the past 8-9 months since Dec 2013?) or it's a software issue...which will mean I've to reflash my stock rom.

Anyone with a similar issue please help! It's kinda driving me nuts cos I can't even unlock my phone without triggering a bootloop...
Might want to send it in for repair. Mine had the same symptoms about a month ago--spontaneously displaying the power menu, boot loops where I'd need to do a hardware reboot (or whatever it's called, vol up + power) and sometimes it won't wake the screen when I press the power button and act as if I turned it off. Tried to reflash recovery and change roms, same banana. Then suddenly it won't go out of bootloop, sometimes gets to the x-boot and sometimes only until the Google logo. Sent it for repair and lo and behold, hardware problem. I think this is really inherent on some older Nexus 5's with the wobbly power button.

I suggest you do a nandroid backup while you have the chance. Never had a chance myself
 
ultimaflux
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Aug 2014
Quote:
Originally Posted by kisetsu17 View Post
Might want to send it in for repair. Mine had the same symptoms about a month ago--spontaneously displaying the power menu, boot loops where I'd need to do a hardware reboot (or whatever it's called, vol up + power) and sometimes it won't wake the screen when I press the power button and act as if I turned it off. Tried to reflash recovery and change roms, same banana. Then suddenly it won't go out of bootloop, sometimes gets to the x-boot and sometimes only until the Google logo. Sent it for repair and lo and behold, hardware problem. I think this is really inherent on some older Nexus 5's with the wobbly power button.

I suggest you do a nandroid backup while you have the chance. Never had a chance myself
sigh, i reflashed stock rom and the problem persisted. i can't even stay on the bootloader screen without it rebooting itself all over again. i guess it's an old nexus 5 hardware problem like you said :/ thanks for sharing!
 
Lethargy
Old
#4  
Lethargy's Avatar
Senior Member
Thanks Meter 1,635
Posts: 2,931
Join Date: Jan 2014
Location: Sydney, Australia
Quote:
Originally Posted by ultimaflux View Post
sigh, i reflashed stock rom and the problem persisted. i can't even stay on the bootloader screen without it rebooting itself all over again. i guess it's an old nexus 5 hardware problem like you said :/ thanks for sharing!
http://forum.xda-developers.com/goog...sions-t2597276
Quote:
Originally Posted by kyphur
You ask us to understand your position. Well if you want to benefit from our experience and time then I think it is only fair that you understand our position.
I actively add ignorant people to my ignore list.
 
krs360
Old
#5  
krs360's Avatar
Senior Member
Thanks Meter 174
Posts: 466
Join Date: Dec 2007
Location: Moretonhampstead
Sounds like the power button is getting stuck, or shorting out.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes