5,605,120 Members 37,543 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Camera not working with ART

Tip us?
 
Caebron
Old
#1  
Caebron's Avatar
Senior Member - OP
Thanks Meter 11
Posts: 192
Join Date: May 2010
Default [Q] Camera not working with ART

The stock camera app stops working when using ART, getting a message "Unable to connect to camera". It works fine again when I switch back to Dalvik. Running 4.4.2 stock, Franco Kernel, TWRP recovery.

How do I troubleshoot this?
Nexus 5 (current) Cataclysm ROM, Franco Kernel
MB886 (retired) NottachTrix ROM, Faux 123 Kernel
 
markdapimp
Old
#2  
Senior Member
Thanks Meter 304
Posts: 1,199
Join Date: Nov 2013
Quote:
Originally Posted by Caebron View Post
The stock camera app stops working when using ART, getting a message "Unable to connect to camera". It works fine again when I switch back to Dalvik. Running 4.4.2 stock, Franco Kernel, TWRP recovery.

How do I troubleshoot this?
Might be the kernel? im on 100% Stock with ART camera works fine
Devices: Nexus 5 (Sold) 1X
Nexus 5
HTC One
 
Caebron
Old
(Last edited by Caebron; 25th December 2013 at 07:44 AM.)
#3  
Caebron's Avatar
Senior Member - OP
Thanks Meter 11
Posts: 192
Join Date: May 2010
Quote:
Originally Posted by markdapimp View Post
Might be the kernel? im on 100% Stock with ART camera works fine
Not according to Francisfranco, the dev of this kernel.

Sent from my Nexus 5 using xda app-developers app
Nexus 5 (current) Cataclysm ROM, Franco Kernel
MB886 (retired) NottachTrix ROM, Faux 123 Kernel
 
markdapimp
Old
#4  
Senior Member
Thanks Meter 304
Posts: 1,199
Join Date: Nov 2013
Quote:
Originally Posted by Caebron View Post
Not according to Francisfranco, the dev of this kernel.

Sent from my Nexus 5 using xda app-developers app
try fix permissions if that even is a thing now lol
Devices: Nexus 5 (Sold) 1X
Nexus 5
HTC One
 
simms22
Old
#5  
simms22's Avatar
Recognized Contributor
Thanks Meter 18099
Posts: 22,705
Join Date: Jun 2009
Location: BROOKLYN!
try fixung permissions in your recovery, if youre running a custom recovery.
Google+ Profile
Twitter Simms22
DerKernel For Trinity kernels and more!
 
markdapimp
Old
#6  
Senior Member
Thanks Meter 304
Posts: 1,199
Join Date: Nov 2013
Quote:
Originally Posted by simms22 View Post
try fixung permissions in your recovery, if youre running a custom recovery.
I beat you to it!
Devices: Nexus 5 (Sold) 1X
Nexus 5
HTC One
 
simms22
Old
#7  
simms22's Avatar
Recognized Contributor
Thanks Meter 18099
Posts: 22,705
Join Date: Jun 2009
Location: BROOKLYN!
Quote:
Originally Posted by markdapimp View Post
try fix permissions if that even is a thing now lol
good timing
Google+ Profile
Twitter Simms22
DerKernel For Trinity kernels and more!
 
markdapimp
Old
#8  
Senior Member
Thanks Meter 304
Posts: 1,199
Join Date: Nov 2013
Quote:
Originally Posted by simms22 View Post
good timing
Yeah i changed my brain to ART too it pre-compiled what you were going to type
Devices: Nexus 5 (Sold) 1X
Nexus 5
HTC One
 
simms22
Old
#9  
simms22's Avatar
Recognized Contributor
Thanks Meter 18099
Posts: 22,705
Join Date: Jun 2009
Location: BROOKLYN!
Quote:
Originally Posted by markdapimp View Post
Yeah i changed my brain to ART too it pre-compiled what you were going to type
ha
Google+ Profile
Twitter Simms22
DerKernel For Trinity kernels and more!
 
Caebron
Old
#10  
Caebron's Avatar
Senior Member - OP
Thanks Meter 11
Posts: 192
Join Date: May 2010
Hm, the problem resolved itself after switching back to ART once more.
Nexus 5 (current) Cataclysm ROM, Franco Kernel
MB886 (retired) NottachTrix ROM, Faux 123 Kernel

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...