CyanogenMod 11.0 Build Error

71 posts
Thanks Meter: 5
By atrohde, Member on 31st January 2014, 02:00 PM
Post Reply Subscribe to Thread Email Thread
I'm getting this build error when trying to compile CM-11.0. When this error occurs, I can try compiling again (brunch hammerhead) and the error will go away but pop up in another section as you can see in the pastebin. I've setup another directory where I re-synced the stock cm-11.0 repo and was able to complete the build. Upon installing the phone failed to boot, so I'm not sure what happened there (I think it was my proprietary files). The only changes I've made to the stock cm version are I've forked frameworks_base, apps_Settings, and the android manifest. I've been able to compile with the forks in the past, but when I forked the android manifest that's when this error started popping up.

Windows 8.1
VMWare : Ubuntu 13.10
Java : Initially was using Oracle version 7 but switched to openjdk 6 to try and troubleshoot
31st January 2014, 06:52 PM |#2  
OP Member
Flag Milwaukee
Thanks Meter: 5
Solved: I've solved this issue but don't know why it was occurring in the first place. It was due to my lack of understanding of repo and git. When I was fetching and and merging the upstream changes, I wasn't committing and pushing those back to my forked repo. Once I did that everything went back to normal.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes