Post Reply

[Q] Never in Deep Sleep *backup* always running?

OP alexs77

21st January 2014, 08:56 PM   |  #1  
OP Member
Thanks Meter: 3
 
48 posts
Join Date:Joined: Mar 2011
Hi

I've got an issue with my stock and rooted Nexus 5 (4.4.2). Based on what Better Battery Stats shows, the device is always Awake (see attached screenshot "Nexus-5-Never-Sleeps_c.jpg"), or, put differently, never in Deep Sleep (→ "Nexus-5-Never-Sleeps_g.jpg"). Additionally, I see that there's a *backup* Partial Wakelock, which is always running (→ "Nexus-5-Never-Sleeps_d.jpg").

While the battery drain isn't that bad (-17% in 7 hours), I still find that pretty strange. The device was "idle" all that time (ie. just lying there, with constant Wi-Fi and screen basically always off, receiving SMS and vibrating at times).

I have switched from 4G to 3G data connection and have disabled Dropbox photo sync. I also turned off Google+ pictures auto backup (and also sync of Google Fotos and Google+ Fotos in the account sync settings).

Hm, ja, well, how to allow the device to go to sleep/how to find out, what's keeping it awake? What's that *backup* wake lock?

Thanks,
Alexander
Attached Thumbnails
Click image for larger version

Name:	Nexus-5-Never-Sleeps_a.jpg
Views:	421
Size:	114.8 KB
ID:	2530780   Click image for larger version

Name:	Nexus-5-Never-Sleeps_b.jpg
Views:	431
Size:	97.5 KB
ID:	2530781   Click image for larger version

Name:	Nexus-5-Never-Sleeps_c.jpg
Views:	381
Size:	153.3 KB
ID:	2530782   Click image for larger version

Name:	Nexus-5-Never-Sleeps_d.jpg
Views:	411
Size:	163.1 KB
ID:	2530783   Click image for larger version

Name:	Nexus-5-Never-Sleeps_e.jpg
Views:	298
Size:	165.6 KB
ID:	2530784   Click image for larger version

Name:	Nexus-5-Never-Sleeps_f.jpg
Views:	329
Size:	131.6 KB
ID:	2530785   Click image for larger version

Name:	Nexus-5-Never-Sleeps_g.jpg
Views:	304
Size:	151.3 KB
ID:	2530786   Click image for larger version

Name:	Nexus-5-Never-Sleeps_h.jpg
Views:	301
Size:	175.0 KB
ID:	2530787  
21st January 2014, 09:10 PM   |  #2  
Senior Member
Flag Toronto
Thanks Meter: 327
 
1,389 posts
Join Date:Joined: Nov 2013
More
That is strange. Hopefully someone can chime in on what backup might be doing but if I ever notice something running abnormally long like that a phone reboot usually fixes it right up.
21st January 2014, 09:12 PM   |  #3  
_MetalHead_'s Avatar
Senior Member
Flag Chicagoland
Thanks Meter: 2,274
 
5,492 posts
Join Date:Joined: Jun 2010
More
17% in 7 hours is horrible. I lose maybe 3% in the same amount of time. Have you tried disabling your wifi? Or changing the sleep policy to "only when plugged in" or "never"?

Also, do you have your N5 setup to backup to google servers? I'd disable that as well.
Last edited by _MetalHead_; 21st January 2014 at 09:15 PM.
21st January 2014, 09:52 PM   |  #4  
FuMMoD's Avatar
Recognized Contributor
Flag South Florida
Thanks Meter: 2,224
 
4,516 posts
Join Date:Joined: Mar 2009
Donate to Me
More
What app did you use to edit your pictures?

Sent from my Nexus 5 using Tapatalk
21st January 2014, 10:19 PM   |  #5  
OP Member
Thanks Meter: 3
 
48 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by bblzd

That is strange. Hopefully someone can chime in on what backup might be doing but if I ever notice something running abnormally long like that a phone reboot usually fixes it right up.

Yeah, a reboot often fixes it - I think I rebooted already. Will do now and report back tomorrow night. Thx.
21st January 2014, 10:21 PM   |  #6  
OP Member
Thanks Meter: 3
 
48 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by _MetalHead_

17% in 7 hours is horrible. I lose maybe 3% in the same amount of time. Have you tried disabling your wifi? Or changing the sleep policy to "only when plugged in" or "never"?

Also, do you have your N5 setup to backup to google servers? I'd disable that as well.

Disable wifi? How to get data then? That's no solution, as the N5 is then just a paper weight. Data is too expensive and slow.

I have backup enabled. And, well, for kicks and giggles, I'll disable that as well (after tomorrow, as to not mix up results with having rebooted). Where do I disable backup exactly?
21st January 2014, 10:22 PM   |  #7  
OP Member
Thanks Meter: 3
 
48 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by FuMMoD

What app did you use to edit your pictures?

Sent from my Nexus 5 using Tapatalk

Skitch → https://play.google.com/store/apps/d...vernote.skitch
The Following User Says Thank You to alexs77 For This Useful Post: [ View ]
21st January 2014, 10:27 PM   |  #8  
Senior Member
Flag Toronto
Thanks Meter: 327
 
1,389 posts
Join Date:Joined: Nov 2013
More
Quote:
Originally Posted by alexs77

Disable wifi? How to get data then? That's no solution, as the N5 is then just a paper weight. Data is too expensive and slow.

I have backup enabled. And, well, for kicks and giggles, I'll disable that as well (after tomorrow, as to not mix up results with having rebooted). Where do I disable backup exactly?

I'm not 100% sure what that *backup* represents but I would guess it's the one you can find in Settings under Personal called Backup & Reset. It could also be related to Auto Sync.
21st January 2014, 10:27 PM   |  #9  
_MetalHead_'s Avatar
Senior Member
Flag Chicagoland
Thanks Meter: 2,274
 
5,492 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by alexs77

Disable wifi? How to get data then? That's no solution, as the N5 is then just a paper weight. Data is too expensive and slow.

I have backup enabled. And, well, for kicks and giggles, I'll disable that as well (after tomorrow, as to not mix up results with having rebooted). Where do I disable backup exactly?

I'm not saying permanently disable wifi, just when you aren't using it. You can set your wifi to sleep when the phone sleeps. When you turn your screen back on, your wifi will turn back on as well. It's in advanced settings.

For backup, there is an option in settings called "backup and reset".
21st January 2014, 11:12 PM   |  #10  
FuMMoD's Avatar
Recognized Contributor
Flag South Florida
Thanks Meter: 2,224
 
4,516 posts
Join Date:Joined: Mar 2009
Donate to Me
More
Ok in wifi go into settings and disable wifi analyze, in locations select Battery saver, if you have app Ops then use it to disable location in the Google play services.

Sent from my Nexus 5 using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Nexus 5 Q&A, Help & Troubleshooting by ThreadRank