Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q]Can't find a directory

OP otacon507

20th August 2014, 11:19 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
29 posts
Join Date:Joined: Oct 2012
Hi all,
Im running CM11 on my N5, and I recently just made 2 backups on CWM. Problem is, CWM says they are in sdcard/clockworkmod/backup, however /backup is not within that directory. The two backups show up in CWM and they are for surely taking up ~2gigs of my hard drive. I tried searching in root explorer for the backups; nothing. I would like to retrieve the backups (for my sanity); or at the very least delete them to save what little HD space I have. Help is greatly appreciated

Thank you for reading


otacon507

**UPDATE**
OK, so a closer investigation revealed that there are two clockworkmod directories, however I still cannot access the pertinent one. The one I can access is at /sdcard/0/clockworkmod; however I require to go to sdcard/clockworkmod/backup as mentioned above. again, thanks for reading

**FINAL UPDATE**

It turns out the backups are in /mnt/shell/emulated/clockworkmod/backup
Please tell me why, but now we know
Last edited by otacon507; 20th August 2014 at 11:34 AM. Reason: SOLVED
20th August 2014, 11:45 AM   |  #2  
Primokorn's Avatar
Recognized Contributor
Thanks Meter: 2,691
 
4,788 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Quote:
Originally Posted by otacon507

/mnt/shell/emulated/clockworkmod/backup

AFAIK it has always been like that.
20th August 2014, 12:25 PM   |  #3  
rootSU's Avatar
Senior Member
Flag Oxenhope, West Yorkshire, UK
Thanks Meter: 13,481
 
24,590 posts
Join Date:Joined: Aug 2010
More
Quote:
Originally Posted by otacon507

It turns out the backups are in /mnt/shell/emulated/clockworkmod/backup
Please tell me why, but now we know


Its all covered in my N5 data thread, which you can get to via my signature for sticky threads.

However in brief, /sdcard USED to be mounted at /data/media on FUSE devices, up until Android 4.2, when they introduced multi-user support. From then on, /sdcard was mounted to /data/media/0 (0 being the default user of your phone)

Where as other, better, recoveries put in a detection method to detect where /sdcard was actually mounted (0 or not), CWM simply didn't bother and left their mount point for /sdcard as /data/media in recovery, which is wrong on SO MANY levels. Lazy development and since the original dev has very little to do with CWM any more and its almost entirely community driven, CWM is not a good option for a choice of recovery. Use Philz or TWRP.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes