5,600,182 Members 38,945 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Emoji broken after 4.4.1 update?

Tip us?
 
muddog
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Mar 2011
Default [Q] Emoji broken after 4.4.1 update?

Hi all,

I just updated my Nexus 5 to 4.4.1. After exchanging a few emails with a friend of mine, I noticed that gmail wasn't displaying emojis properly. When composing a message, I can input emoji no problem and they appear fine but after I send the email, all the recipient and I can see is something like this:

Code:
&#xxxxxx;
where xxxxxx is some kind of emoji number. Downgrading gmail, downgrading google keyboard or using the iWinn emoji keyboard gave me the same result. Downgrading to 4.4 fixed the problem. I'd much rather stay on 4.4.1 because of the camera improvements. Has anyone else come across this problem? Does anyone have any ideas how to fix it?

Thanks!
 
jstierman
Old
(Last edited by jstierman; 13th December 2013 at 08:39 PM.)
#2  
Junior Member
Thanks Meter 2
Posts: 16
Join Date: Dec 2011
Location: Southfield, MI
I'm having this problem, too, on my Nexus 5 and Nexus 7 (2013 version) since the 4.4.2 update. I can read other people's emoji (from iPhone) but can't send. When I look in my sent box, the emoji are broken there (#&xxxxxx), too.

edit: appeard to be still working in my twitter app, but not the gmail app

update:
It appears that certain emoji work and others do not, for example I tried a random set of 10-ish:
😀😯♋♉👓👑🐏🐤⛪🏠
Those two in the middle are the working ones.

The "source" (go into gmail website and hit "original message" on the email) looks like the following:
😀😯=E2=99=8B=E2=99=89👓👑🐏🐤=E2=
=9B=AA🏠

Going to try to downgrade to 4.4 probably, if this doesn't get fixed somehow... or try CM.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes