5,600,335 Members 35,046 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Exchange services still draining battery

Tip us?
 
sonicice
Old
(Last edited by sonicice; 1st January 2014 at 06:18 PM.)
#1  
Member - OP
Thanks Meter 10
Posts: 48
Join Date: Sep 2007
Default [Q] Exchange services still draining battery

On 4.4.2, and I'm still seeing the exchange wakelocks when my syncing is set to Push.

Wakelock detector is showing that the Email sync is whats causing the wakelock. Right now it's showing 1hr 47m x15237.

Email syncing still seems to be working. When I look at the corporate account in the settings, I see it constantly going between Syncing and the last sync date/time. Is that normal? I've tried deleting the account, clearing cache and data of email and exchange services and it still is happening.

I thought this was supposed to be fixed in 4.4.1 or 4.4.2 but this battery drain is just killing me... I'm at 39% with only 1 hour on screen time because of it.

If I change the option to sync to 5 minutes it's fine... but Push sync is just destroying me.

Sorry if this post is disjointed.. anyone else still experiencing this?
 
b1g1an
Old
#2  
Senior Member
Thanks Meter 41
Posts: 204
Join Date: Nov 2011
Mine does it every couple of weeks or so, just click sync off and then on again and it'll be fine for another couple of weeks. Haven't worked out what's kicking it off but it seems to happen not long after a restart bit not every time.

Sent from my Nexus 5 using Tapatalk
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes