FORUMS

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

Android 5.1.1 Omni ROM For Motorola Xoom

Back in Feb 2011, the Motorola Xoom became the first device to be sold with Android 3.0 … more

Flash speed

101 posts
Thanks Meter: 32
 
By Jacob030, Senior Member on 17th March 2014, 04:34 AM
Post Reply Subscribe to Thread Email Thread
Has anyone else noticed that the flash is really slow on 4.4.2? I used flash alerts pro since 4.4 and on 4.4 I could set the flash to blink 6 times or more in under a second. Now on 4.4.2 its more like 2-3 times. I am currently running Liquid Smooth and its the same. I tested with the torch app and no change. Anyone know why?

Sent from my Nexus 5 using Tapatalk
 
 
17th March 2014, 05:51 AM |#2  
RevelationOmega's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 585
 
Donate to Me
More
Quote:
Originally Posted by Jacob030

Has anyone else noticed that the flash is really slow on 4.4.2? I used flash alerts pro since 4.4 and on 4.4 I could set the flash to blink 6 times or more in under a second. Now on 4.4.2 its more like 2-3 times. I am currently running Liquid Smooth and its the same. I tested with the torch app and no change. Anyone know why?

Sent from my Nexus 5 using Tapatalk

Could be where the torch app was merged from. The torch app on Carbon ROM is very fast, no lag/stutter what so ever. On other ROMs however, I have noticed the latent period from the click activity and the actual flash coming on. If you check the repo where the torch was merged from, that's probably why. Many use CM yet lately, is had issues. See if any differences between the ROMs and that'll probably answer why so lagged flash.
17th March 2014, 06:09 AM |#3  
OP Senior Member
Thanks Meter: 32
 
More
Quote:
Originally Posted by RevelationOmega

Could be where the torch app was merged from. The torch app on Carbon ROM is very fast, no lag/stutter what so ever. On other ROMs however, I have noticed the latent period from the click activity and the actual flash coming on. If you check the repo where the torch was merged from, that's probably why. Many use CM yet lately, is had issues. See if any differences between the ROMs and that'll probably answer why so lagged flash.

See that's the thing. Its not just the torch app. Its every app that has a strobe setting. Its like the flash can't flash fast enough. Maybe something is different in the kernel that changed the flash rate. It worked fine on stock 4.4, but not on stock 4.4.2. Weird........

Sent from my Nexus 5 using Tapatalk
17th March 2014, 03:40 PM |#4  
RevelationOmega's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 585
 
Donate to Me
More
Quote:
Originally Posted by Jacob030

See that's the thing. Its not just the torch app. Its every app that has a strobe setting. Its like the flash can't flash fast enough. Maybe something is different in the kernel that changed the flash rate. It worked fine on stock 4.4, but not on stock 4.4.2. Weird........

Sent from my Nexus 5 using Tapatalk

The torch app is the cause, it's been reported a lot. With a faulty torch app, as I've read across many boards, the flash "happens to early in camera" or "not working" or "laggy". The flash rate, in your case, is probably due to this as well. With new merged torch from either CM or other sources lately, there has been A LOT of reports against it working/misfunction. What I can say is, try flash another ROM that works (could try Carbon ROM) and test the flash/strobing effects. If it works on that ROM, then it's the liquid smooth ROM/torch. If not, then it's the phone. But I looked into liquid smooth before but lately, they've had problems, one being the torch app.
17th March 2014, 08:42 PM |#5  
OP Senior Member
Thanks Meter: 32
 
More
Quote:
Originally Posted by RevelationOmega

The torch app is the cause, it's been reported a lot. With a faulty torch app, as I've read across many boards, the flash "happens to early in camera" or "not working" or "laggy". The flash rate, in your case, is probably due to this as well. With new merged torch from either CM or other sources lately, there has been A LOT of reports against it working/misfunction. What I can say is, try flash another ROM that works (could try Carbon ROM) and test the flash/strobing effects. If it works on that ROM, then it's the liquid smooth ROM/torch. If not, then it's the phone. But I looked into liquid smooth before but lately, they've had problems, one being the torch app.

Here's vids of what I mean.

Stock 4.4

http://youtu.be/IzVoLCKMInM

Stock 4.4.2

http://youtu.be/QvkN6x0Dto0
17th March 2014, 10:18 PM |#6  
RevelationOmega's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 585
 
Donate to Me
More
Quote:
Originally Posted by Jacob030

Here's vids of what I mean.

Stock 4.4

http://youtu.be/IzVoLCKMInM

Stock 4.4.2

http://youtu.be/QvkN6x0Dto0

I see what you're saying, flash is slower. The reason, being on custom ROM and that the updates to Kitkat have been battery drain and camera issues are probably causing you the issue. The update to 4.4.2 probably caused the problem because of upgrades to camera/torch files. As before, if test another ROM quick and see if issue persist. If so, then it's 4.4.2 and, if not, then it was ROM related. Only reasons and change.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes