Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Lean Mean Battery Power Saving App Review

We talk a lot about battery topics here at XDA TV. We talk about everything from Power Banks to USB … more

Android 5.1 Possibly Coming February 2015

Google released Android 5.0 just over a month ago, and since then Lollipop has been trying to … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q]Google Dialer Keeps Phone Awake

OP _jordan_

13th June 2014, 04:53 PM   |  #1  
_jordan_'s Avatar
OP Senior Member
Thanks Meter: 90
 
391 posts
Join Date:Joined: Oct 2013
I have noticed one of my biggest battery draining apps is the google dialer application.

For some reason it seems to keep the phone awake for hours on end, even when I do not spend very much time on the phone.

Stock, 4.4.3. rooted, thats it.

Any suggestions or ideas? I've tried clearing the dialer's cache and data, but it still keeps the device awake for no reason it seems.

Thanks in advance!
19th June 2014, 03:38 AM   |  #2  
_jordan_'s Avatar
OP Senior Member
Thanks Meter: 90
 
391 posts
Join Date:Joined: Oct 2013
Anyone? Here are some screen shots.



Sent from my Nexus 5 using Tapatalk
19th June 2014, 07:56 AM   |  #3  
raul90's Avatar
Member
Flag Monterrey
Thanks Meter: 17
 
87 posts
Join Date:Joined: Jan 2012
More
mmh I've never seen that problem.

You could first try clearing data and cache of the app. If that doesn't work, maybe flash the factory images? Just to be sure it's not something on your side.

Hope this helps.

Sent from my Nexus 5 using Tapatalk
20th June 2014, 01:15 AM   |  #4  
_jordan_'s Avatar
OP Senior Member
Thanks Meter: 90
 
391 posts
Join Date:Joined: Oct 2013
Thanks. Tried both of those. No luck .

I re flashed last evening and the bug is still there

Sent from my Nexus 5 using Tapatalk
20th June 2014, 04:01 AM   |  #5  
taodan's Avatar
Senior Member
Thanks Meter: 219
 
933 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by _jordan_

Thanks. Tried both of those. No luck .

I re flashed last evening and the bug is still there

Sent from my Nexus 5 using Tapatalk

Boot the phone into recovery and then wipe cache and dalvik cache, and then reboot the phone.
20th June 2014, 08:00 AM   |  #6  
raul90's Avatar
Member
Flag Monterrey
Thanks Meter: 17
 
87 posts
Join Date:Joined: Jan 2012
More
I think 4.4.4 addresses this issue, you should make a clean installation of the factory image (again) and see how it goes.

Sent from my Nexus 5 using Tapatalk
20th June 2014, 08:27 PM   |  #7  
_jordan_'s Avatar
OP Senior Member
Thanks Meter: 90
 
391 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by raul90

I think 4.4.4 addresses this issue, you should make a clean installation of the factory image (again) and see how it goes.

Sent from my Nexus 5 using Tapatalk

I flashed the 4.4.4 system and radio images.

Will report back. So far so good..... But I will confirm.

Sent from my Nexus 5 using Tapatalk
21st June 2014, 12:40 AM   |  #8  
_jordan_'s Avatar
OP Senior Member
Thanks Meter: 90
 
391 posts
Join Date:Joined: Oct 2013
OK SO i think i MAY have figured out this bug.

I use the search function in the dialer app all the time for work. I call a lot of businesses in the area and i always use the dialer to look up their numbers. This is what I think causes the wakelock, as it triggers a search and looks up local businesses matching the number.

I've turned off this feature in the app, as well as the caller ID function and so far i am not having any issues. Will report back.
30th July 2014, 03:16 AM   |  #9  
_jordan_'s Avatar
OP Senior Member
Thanks Meter: 90
 
391 posts
Join Date:Joined: Oct 2013
Just an update. I can trigger this bug in any ROM, including cyanogen mod and also paranoid android.

Here is the solution until Google offers a fix:



By leaving the above options unchecked, the wake lock will not trigger.



Sent from my Nexus 5 using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes