Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Google Maps. GPS Slow?

OP andrawer

5th February 2014, 01:29 AM   |  #1  
OP Senior Member
Thanks Meter: 148
 
679 posts
Join Date:Joined: Jun 2011
More
While using WIFI, calculating driving routes using Google Maps/GPS is super fast...as expected.
However, when I'm using my AT&T LTE data connection it seems to take forever to calculate a route or give results when using Google Map app to search for something (i.e. gas station).

Really frustrating, reroutes can take a minute+ and route calculation in general is slow. It often says "waiting for location"? Huh, I got 3+ bars and GPS signal on fast(?). Sometimes reboot fixes it for a short while.

Any thoughts if there is anything I can do to speed up the GPS (factory reset?). I don't remember this happening the first few months of ownership and wonder if it is the latest update (a month ago???).

Trying to figure if the problem resides with AT&T, google maps, or N5 GPS?

---
*Running full stock and have owned my N5 for 3 months now which speaks to how much I enjoy my Nexus 5 (first time nexus versus a long string of Samung and a few LG phones).


Thanks!!
Last edited by andrawer; 5th February 2014 at 02:17 AM.
5th February 2014, 02:14 AM   |  #2  
RevelationOmega's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 542
 
535 posts
Join Date:Joined: Jan 2014
Donate to Me
More
Quote:
Originally Posted by andrawer

While using WIFI, calculating driving routes using Google Maps/GPS is super fast...as expected.
However, when I'm using my AT&T LTE data connection it seems to take forever to calculate a route or give results when using Google Map app to search for something (i.e. gas station).

Really frustrating, reroutes can take a minute+ and route calculation in general is slow. It often says "waiting for location"? Huh, I got 3+ bars and GPS signal on fast(?). Sometimes reboot fixes it for a short while.

Any thoughts if there is anything I can do to speed up the GPS (factory reset?). I don't remember this happening the first few months of ownership and wonder if it is the latest update (a month ago???).

Trying to figure if the problem resides with AT&T, google maps, or N5 GPS?

---
*Running full stock and have owned my N5 for 3 months now which speaks to how much I enjoy my Nexus 5 (first time nexus versus a long string of Samung and a few LG phones).


Thanks!!

Did you update to most recent Google Maps that was just released via play store? How long has then been happening? Mine has worked well in battery saving/high accuracy modes enabled from Sprint so I'd say the issue probably may reside with AT&T or the GPS lastly.
The Following User Says Thank You to RevelationOmega For This Useful Post: [ View ]
5th February 2014, 02:23 AM   |  #3  
OP Senior Member
Thanks Meter: 148
 
679 posts
Join Date:Joined: Jun 2011
More
Quote:
Originally Posted by RevelationOmega

Did you update to most recent Google Maps that was just released via play store? How long has then been happening? Mine has worked well in battery saving/high accuracy modes enabled from Sprint so I'd say the issue probably may reside with AT&T or the GPS lastly.

Good catch, I have today's latest Google Maps (Feb 4, 2014) and didn't even realize I updated it...and haven't tested it yet.

BUT, I called google support and we just cleared cache and data on the apps/Map and the Map/GPS seems to work fine now...so I don't know if it was the new Google Maps or Cache clear? oh well, will test over the next few days and report back.

A thread on googleproductforum led me to believe it was a hardware issue...i shall see.

https://productforums.google.com/for...B1-25-false%5D
5th February 2014, 02:25 AM   |  #4  
RevelationOmega's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 542
 
535 posts
Join Date:Joined: Jan 2014
Donate to Me
More
Quote:
Originally Posted by andrawer

Good catch, I have today's latest Google Maps (Feb 4, 2014) and didn't even realize I updated it...and haven't tested it yet.

BUT, I called google support and we just cleared cache and data on the apps/Map and the Map/GPS seems to work fine now...so I don't know if it was the new Google Maps or Cache clear? oh well, will test over the next few days and report back.

A thread on googleproductforum led me to believe it was a hardware issue...i shall see.

https://productforums.google.com/for...B1-25-false%5D

Good luck. Hopefully it isn't something to extreme.
3rd April 2014, 09:52 PM   |  #5  
Member
Thanks Meter: 17
 
87 posts
Join Date:Joined: Apr 2014
There are a lot of threads here about GPS issues with the N5. So in your case it's probably the GPS, too.
As far as I have read them, RMAing the device should be considered.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes