Build an Impractical But Awesome Lego Mindstorm Dock

The vast majority of what we cover here on the XDA-Developers News Portal relates to … more

MultiROM Makes its Way Over to the HTC One (M8)

While browsing our forum, you will undoubtedly find more than a few enticing ROMs available … more

Welcome to the New XDA-Developers Portal!

You may recall that a few weeks ago, we opened up the XDA-2015 forum themesto intrepid users … more

An Android Enthusiast’s Apple iPhone 6 Challenge

The media has gone batty again over Apple “revolutionizing” smartphones. … more
Post Reply

[Q] Need help with com.android.systemui has stopped working

8th January 2014, 12:08 PM   |  #1  
OP Senior Member
Thanks Meter: 29
 
829 posts
Join Date:Joined: Nov 2010
More
Hi all,

everytime I reboot the phone I get this error message.
I think it's because I used titanium backup to delete 3 files which had to do with korean / hindu and another language file or something similar...

besides the screenshot, I have no idea how to provide logs.

Appreciate the assistance.



Attached LOGCAT
Attached Files
File Type: zip logcat.zip - [Click for QR Code] (85.8 KB, 21 views)
Last edited by gil80; 8th January 2014 at 01:36 PM.
8th January 2014, 01:48 PM   |  #2  
jd1639's Avatar
Recognized Contributor
Minnetonka, MN
Thanks Meter: 3,396
 
9,938 posts
Join Date:Joined: Sep 2012
Pretty sure it's the files you deleted. Are you on stock rom? If so, just flash the system.img. If custom Rom, dirty flash it
8th January 2014, 01:56 PM   |  #3  
OP Senior Member
Thanks Meter: 29
 
829 posts
Join Date:Joined: Nov 2010
More
If I'll flash system.img, then I'll lose some settings.

Is there a way to download the system apps or open the .img file?

if none of the above, can you please see if there's an error in the logcat?
8th January 2014, 02:20 PM   |  #4  
Senior Member
Thanks Meter: 535
 
2,778 posts
Join Date:Joined: May 2010
Donate to Me
More
Quote:
Originally Posted by gil80

If I'll flash system.img, then I'll lose some settings.

Is there a way to download the system apps or open the .img file?

if none of the above, can you please see if there's an error in the logcat?

Download a stock rom zip (make sure you get the deodex or odex one that matches your current set up) and open zip. Browse to /system/app/ and pick the apks you need. Move them to your internal storage and use a file explorer with root access to copy to the /system/app folder in your phone. Make sure you change the permissions and reboot. IF that is what caused it, that will get you back to normal. If it doesn't, then just dirty flash. You really won't lose that much stuff.

Also, sometimes just clearing caches and fixing permissions in recovery can help, and if it doesn't, it won't make it worse.

If you need more help, make sure you post quote or hit me up on Hangouts.
8th January 2014, 02:33 PM   |  #5  
OP Senior Member
Thanks Meter: 29
 
829 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by es0tericcha0s

Download a stock rom zip (make sure you get the deodex or odex one that matches your current set up) and open zip. Browse to /system/app/ and pick the apks you need. Move them to your internal storage and use a file explorer with root access to copy to the /system/app folder in your phone. Make sure you change the permissions and reboot. IF that is what caused it, that will get you back to normal. If it doesn't, then just dirty flash. You really won't lose that much stuff.

Also, sometimes just clearing caches and fixing permissions in recovery can help, and if it doesn't, it won't make it worse.

If you need more help, make sure you post quote or hit me up on Hangouts.

looking at the logcat I uploaded I searched for "fatal" and it found 1 fatal issue which is com.android.systemui and it appears to be something with the battery icon which I changed using GravityBox. But the change was a week ago so I don't know what was changed.
Switching back to stock battery icon and I no longer have this issue.

But it seems that I have more errors on the log file. Do you of a forum which can assist with understanding the errors I have and how to fix them?
20th January 2014, 05:05 AM   |  #6  
Senior Member
Thanks Meter: 49
 
973 posts
Join Date:Joined: Jan 2007
Quote:
Originally Posted by gil80

looking at the logcat I uploaded I searched for "fatal" and it found 1 fatal issue which is com.android.systemui and it appears to be something with the battery icon which I changed using GravityBox. But the change was a week ago so I don't know what was changed.
Switching back to stock battery icon and I no longer have this issue.

But it seems that I have more errors on the log file. Do you of a forum which can assist with understanding the errors I have and how to fix them?

I get this after a titanium backup restore. No idea why it does it I mean isn't that what titanium backup is for?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes


Top Threads in Nexus 5 Q&A, Help & Troubleshooting by ThreadRank