Android 5.1 Possibly Coming February 2015

Google released Android 5.0 just over a month ago, and since then Lollipop has been trying to … more

Double Tap to Wake on the Nexus 6 Without Root

A few weeks ago, we featured an app which allowed the Nexus 6 to regain the double tap to wake … more

Make Your Own Heat Sink for the LG Optimus 4X HD

Its not a rare occurrence that performing a resource heavy task on your Android device (e.g. … more

Learn How to Create an Old School Dialer

XDA is not only a great source for custom ROMs, kernels, and various modifications for numerous … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Need help with com.android.systemui has stopped working

OP gil80

8th January 2014, 01:08 PM   |  #1  
OP Senior Member
Thanks Meter: 29
 
852 posts
Join Date:Joined: Nov 2010
More
Hi all,

everytime I reboot the phone I get this error message.
I think it's because I used titanium backup to delete 3 files which had to do with korean / hindu and another language file or something similar...

besides the screenshot, I have no idea how to provide logs.

Appreciate the assistance.



Attached LOGCAT
Attached Files
File Type: zip logcat.zip - [Click for QR Code] (85.8 KB, 27 views)
Last edited by gil80; 8th January 2014 at 02:36 PM.
8th January 2014, 02:48 PM   |  #2  
jd1639's Avatar
Recognized Contributor
Minnetonka, MN
Thanks Meter: 3,896
 
11,181 posts
Join Date:Joined: Sep 2012
Pretty sure it's the files you deleted. Are you on stock rom? If so, just flash the system.img. If custom Rom, dirty flash it
8th January 2014, 02:56 PM   |  #3  
OP Senior Member
Thanks Meter: 29
 
852 posts
Join Date:Joined: Nov 2010
More
If I'll flash system.img, then I'll lose some settings.

Is there a way to download the system apps or open the .img file?

if none of the above, can you please see if there's an error in the logcat?
8th January 2014, 03:20 PM   |  #4  
Senior Member
Thanks Meter: 589
 
3,105 posts
Join Date:Joined: May 2010
Donate to Me
More
Quote:
Originally Posted by gil80

If I'll flash system.img, then I'll lose some settings.

Is there a way to download the system apps or open the .img file?

if none of the above, can you please see if there's an error in the logcat?

Download a stock rom zip (make sure you get the deodex or odex one that matches your current set up) and open zip. Browse to /system/app/ and pick the apks you need. Move them to your internal storage and use a file explorer with root access to copy to the /system/app folder in your phone. Make sure you change the permissions and reboot. IF that is what caused it, that will get you back to normal. If it doesn't, then just dirty flash. You really won't lose that much stuff.

Also, sometimes just clearing caches and fixing permissions in recovery can help, and if it doesn't, it won't make it worse.

If you need more help, make sure you post quote or hit me up on Hangouts.
8th January 2014, 03:33 PM   |  #5  
OP Senior Member
Thanks Meter: 29
 
852 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by es0tericcha0s

Download a stock rom zip (make sure you get the deodex or odex one that matches your current set up) and open zip. Browse to /system/app/ and pick the apks you need. Move them to your internal storage and use a file explorer with root access to copy to the /system/app folder in your phone. Make sure you change the permissions and reboot. IF that is what caused it, that will get you back to normal. If it doesn't, then just dirty flash. You really won't lose that much stuff.

Also, sometimes just clearing caches and fixing permissions in recovery can help, and if it doesn't, it won't make it worse.

If you need more help, make sure you post quote or hit me up on Hangouts.

looking at the logcat I uploaded I searched for "fatal" and it found 1 fatal issue which is com.android.systemui and it appears to be something with the battery icon which I changed using GravityBox. But the change was a week ago so I don't know what was changed.
Switching back to stock battery icon and I no longer have this issue.

But it seems that I have more errors on the log file. Do you of a forum which can assist with understanding the errors I have and how to fix them?
20th January 2014, 06:05 AM   |  #6  
Senior Member
Thanks Meter: 58
 
1,038 posts
Join Date:Joined: Jan 2007
Quote:
Originally Posted by gil80

looking at the logcat I uploaded I searched for "fatal" and it found 1 fatal issue which is com.android.systemui and it appears to be something with the battery icon which I changed using GravityBox. But the change was a week ago so I don't know what was changed.
Switching back to stock battery icon and I no longer have this issue.

But it seems that I have more errors on the log file. Do you of a forum which can assist with understanding the errors I have and how to fix them?

I get this after a titanium backup restore. No idea why it does it I mean isn't that what titanium backup is for?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes