5,815,022 Members 39,621 Now Online
XDA Developers Android and Mobile Development Forum

Wifi draining battery??

Tip us?
 
kingston73
Old
#1  
kingston73's Avatar
Senior Member - OP
Thanks Meter 353
Posts: 1,815
Join Date: Feb 2011
Default Wifi draining battery??

I've only had my nexus for a week now and I'm trying to hunt down the reason I'm getting poor battery life. At first it was nlp wakelocks but that went away on its own somehow. Now its my wifi draining battery, in 8 hours of idle overnight it went from 100% to 79% and wifi was the top usage. I've never seen this before on any phone with any rom so I'm not sure what to do about it.
TmoUS eastcoast
G2 iphone 5
Sensation GS3
BB 9810
Hammer_Of_The_Gods Old
#2  
Guest
Thanks Meter 0
Posts: n/a
Hi,

Try Settings/Wi-Fi/Menu/Advanced/ and untick Scanning always available...
The Following User Says Thank You to For This Useful Post: [ Click to Expand ]
 
Moynia
Old
(Last edited by Moynia; 13th May 2014 at 05:36 PM.)
#3  
Moynia's Avatar
Junior Member
Thanks Meter 10
Posts: 27
Join Date: Nov 2013
Location: New Jersey
This is what I did to improve my battery:

1. Location Services : If you are not in a neighborhood with a lot of wifi spots you will most likely feel this draining your battery life. Under settings make sure that Location Services is set to battery saving and not High accuracy.

2. Widgets : Weather widgets, games eat battery by constantly fetching information . Check the settings for these widgets and make sure they are using wifi and not updating the weather information every 30 mins or so. I keep my settings to update weather information every hour to keep it reasonable. The Gmail widget sometimes eats your battery too. I removed the widget and used an icon in the dock at the bottom to check my email. Another thing I noticed was that some widgets are just more battery intensive than others. For example I found HD widgets consumed nearly twice as much battery as Chronus on the home screen but both displayed the same information.

3. Restart your phone : Sometimes residual processes from closed apps could cause issues. Restart your phone if you haven't done it in a while and it should clear up any unnecessary things.

4. Keep wifi on during sleep : I made sure my phone uses wifi even when its sleeping. 3g / 4g eats the battery like crazy if you turn off wifi when your phone sleeps. This should be a default setting as pointed out by some users. In my case it had been changed probably when I was tinkering with the phone. You can find this setting in the Settings -> Wifi -> advanced -> Keep wifi on during sleep.
You can also use apps like Greenify , Tasker , and Llama.

5. Don't use Automatic Brightness : Turns out if the sensors are constantly looking to adjust brightness it takes up more battery. I set my brightness at around 60% and it works just fine throughout the day.

6. Use wifi over 3G/4G/LTE if possible

7. Switch off wifi when using Data: Android doesnt switch off your WiFi when you use data because Google wants you to use it for Locations and help build their database of networks.Switch off WiFi completely when using data to save a good chunk of battery.

8. Turn off Vibration on touch : Typing uses quite a bit of battery over the course of a day. Try switching Vibration on touch off.

9. Use Franco Kernel: : This will require rooting your device however it makes it a lot more power efficient.

10. Turn down the Facebook refresh rate : Make sure it updates not very often( every 3-4 hours) or never. IMO your phone is better off without Facebook or any other battery hog social networking apps.
The Following 3 Users Say Thank You to Moynia For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes