Firefox OS: 17 Smartphones & 40+ Markets In 2015

The post Firefox OS: 17 Smartphones & 40+ Markets In 2015 appeared first on … more

Samsung Unpacked Coverage: All About the S6

more

Samsung Galaxy S6 Cameras

more

The Battery Behind the Samsung S6 and S6 Edge

more
Post Reply

How I get Wallet to stop using location services?

OP Mindspin_311

2nd February 2014, 09:55 PM   |  #1  
Mindspin_311's Avatar
OP Senior Member
Flag Sandy Springs, GA
Thanks Meter: 33
 
617 posts
Join Date:Joined: Feb 2011
More
No way in the app to turn it off that I can see.



Sent from my Nexus 5
2nd February 2014, 09:59 PM   |  #2  
RevelationOmega's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 570
 
547 posts
Join Date:Joined: Jan 2014
Donate to Me
More
Quote:
Originally Posted by Mindspin_311

No way in the app to turn it off that I can see.



Sent from my Nexus 5

I would use App Ops that are baked into some ROMs (if using custom ROM with this addition) or Play Store the App Ops to see if, by using root, you can access this feature to restrict the Location for the wallet app.
3rd February 2014, 02:14 AM   |  #3  
Senior Member
Thanks Meter: 621
 
3,255 posts
Join Date:Joined: May 2010
Donate to Me
More
Turning off NFC might help as well.
3rd February 2014, 05:39 PM   |  #4  
Mindspin_311's Avatar
OP Senior Member
Flag Sandy Springs, GA
Thanks Meter: 33
 
617 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by es0tericcha0s

Turning off NFC might help as well.

NFC is not on to start with...
3rd February 2014, 06:10 PM   |  #5  
Senior Member
Thanks Meter: 621
 
3,255 posts
Join Date:Joined: May 2010
Donate to Me
More
Quote:
Originally Posted by Mindspin_311

NFC is not on to start with...

Just looked it up and it's not Google Wallet itself that is causing the issue, rather over all location services. You'll probably want to read a bit on this thread: http://forum.xda-developers.com/show...php?p=48051661
11th February 2014, 12:49 AM   |  #6  
lanwarrior's Avatar
Senior Member
Thanks Meter: 151
 
2,194 posts
Join Date:Joined: Mar 2006
Quote:
Originally Posted by es0tericcha0s

Just looked it up and it's not Google Wallet itself that is causing the issue, rather over all location services. You'll probably want to read a bit on this thread: http://forum.xda-developers.com/show...php?p=48051661

I have the same problem and it turns out because Google Wallet have "Offers", which always use Location Services (GPS, Wifi, etc.) to find the "relevant" offers (discounts, etc.) in your area.

I use Google Wallet for payment, but I do NOT need the "Offers" feature. In prior version of Google Wallet, I believe the "Offers" feature is disabled. However, now it is FORCED upon you. I don't see any settings in the Google Wallet app to disable "Offers". Anyone know?
11th February 2014, 10:39 AM   |  #7  
Ben36's Avatar
Senior Member
Thanks Meter: 2,229
 
6,980 posts
Join Date:Joined: Jun 2012
https://play.google.com/store/apps/d....appopsstarter

And just turn off location to everything you don't want having the access. It's a great battery saver too!

Sent from my Nexus 5 using Tapatalk
11th February 2014, 04:28 PM   |  #8  
lanwarrior's Avatar
Senior Member
Thanks Meter: 151
 
2,194 posts
Join Date:Joined: Mar 2006
Quote:
Originally Posted by Ben36

https://play.google.com/store/apps/d....appopsstarter

And just turn off location to everything you don't want having the access. It's a great battery saver too!

Sent from my Nexus 5 using Tapatalk

I have used AppsOps to turn off Location Reporting for Google Wallet, but it seems something is still running that cause Google Wallet to keep causing this issue.

On a sidenote, I froze Google+. It still show up in App Ops for some reason and I see under "Location", it said it was last accessed 4 days ago. Thing is, Google+ is frozen and I got th ephone 2 weeks ago. So something is still running even if the app is in this state. I ended up uninstallign Google+

So I don't know if Google Wallet have the same thing...
11th February 2014, 05:22 PM   |  #9  
PhilipTD's Avatar
Senior Member
Flag New York
Thanks Meter: 399
 
1,766 posts
Join Date:Joined: Dec 2010
More
It stopped happening after I finished setting up my account with a credit card and whatnot.
22nd February 2015, 04:07 AM   |  #10  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Aug 2007
Talking
Quote:
Originally Posted by lanwarrior

I have the same problem and it turns out because Google Wallet have "Offers", which always use Location Services (GPS, Wifi, etc.) to find the "relevant" offers (discounts, etc.) in your area.

I use Google Wallet for payment, but I do NOT need the "Offers" feature. In prior version of Google Wallet, I believe the "Offers" feature is disabled. However, now it is FORCED upon you. I don't see any settings in the Google Wallet app to disable "Offers". Anyone know?

I know what you mean, was annoying to get pop-up offers when driving around. Looking into it, with Wallet open and on the main screen touch the 3 bar icon in the upper left. Hit " settings" then "notifications". On this screen just make sure "nearby items" is switched off (2nd option to the bottom). I hope this helps!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes