Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] inconsistent battery charging - any help?

OP suikerchiller

17th August 2014, 01:50 PM   |  #1  
OP Member
Flag Amsterdam
Thanks Meter: 1
 
43 posts
Join Date:Joined: Jun 2011
Hi guys,

Been having issues with charging for the past couple of days. When I plug my phone into the charger it states that it's charging, but nothing really happens. The troubleshooting so far:
  1. Have tested it on multiple different chargers, all having same problem. However, my Nexus7 tablet will charge normally on these chargers, so we can rule out it's charger related.
  2. Tested for differences with the phone switched on or off. When phone is switched off it will charge, but not with the speed it normally does.
  3. Running CM11 Snapshot M9. Did a clean install. Battery does not charge normally (read 1% gain per 20 min) on most stripped down version (without gapps + personal apps)

Looks like it's battery related. But I find it difficult to rule out what's causing my phone to act funny. The weird thing is that sometimes my phone will go for a decent charge, but this happens so randomly that it's hard to find any form of sense in this process. Also, when the phone is on and charging, the battery light will sometimes turn off. But when I activate my phone again, the battery light will bleep on as if nothing happened and everything is functioning normally (which is clearly doesn't).

Does anybody have an idea how I can fix this? Any helpful tips that can point me into the right direction to figure out what's causing this? Many thanks in advance!
Last edited by suikerchiller; 17th August 2014 at 02:32 PM. Reason: after extra testing
19th August 2014, 12:59 AM   |  #2  
OP Member
Flag Amsterdam
Thanks Meter: 1
 
43 posts
Join Date:Joined: Jun 2011
did some more testing - can anyone help me out?
After some additional testing I'm fairly sure that it's either battery or chip related:
  1. USB debugging does not work at all (storage is set to MTP). When I open Android File Transfer my Mac will recognise the Nexus 7 tablet, but not the Nexus 5. Debugging is switched on in Developer options.
  2. When I try to use adb or fasboot, my device is not listed either, nor are any commands (directed towards phone) executed through bootloader.
  3. In the about Phone section I went to check the Battery info. It will state correctly that the phone is being charged through AC or USB (depending on wether the device is connected to laptop or charger).

Does anyone have an idea how I can figure out if it's chip or battery related? I desperately want to find this out, because I bought my phone in The States and live in Europe... So in the worst case scenario the phone needs to go back to the US due to bureaucratic policies. Already had to go through this horrible proces half a year ago with a bad NAND chip, really want to avoid the hassle and lose my phone for at least a month. So if it's a battery thing I rather order a new one and replace it myself

Really really hope someone can shed light on this issue, running out of luck and options. Please guys, please
19th August 2014, 01:04 AM   |  #3  
simms22's Avatar
Recognized Contributor
BROOKLYN!
Thanks Meter: 22,853
 
27,475 posts
Join Date:Joined: Jun 2009
sounds like the usb connection, physical, is going. if it doesnt charge but randomly will, fastboot nor adb see it, i think its an usb connection issue. i had the same with my nexus one a long time ago, if i wiggled the the connection when it was connected, sometimes i could get it to charge some. fortunately, it isnt an expensive repair, and yours should still be under warranty.
19th August 2014, 01:14 AM   |  #4  
OP Member
Flag Amsterdam
Thanks Meter: 1
 
43 posts
Join Date:Joined: Jun 2011
Quote:
Originally Posted by simms22

sounds like the usb connection, physical, is going. if it doesnt charge but randomly will, fastboot nor adb see it, i think its an usb connection issue. i had the same with my nexus one a long time ago, if i wiggled the the connection when it was connected, sometimes i could get it to charge some. fortunately, it isnt an expensive repair, and yours should still be under warranty.

Thanks for the reply, really appreciate it How much you reckon it will cost? Also, can I do this at any decent phone recovery shop? As stated previously, really want to avoid sending the phone back to the US. Once again thanks!
19th August 2014, 01:17 AM   |  #5  
simms22's Avatar
Recognized Contributor
BROOKLYN!
Thanks Meter: 22,853
 
27,475 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by suikerchiller

Thanks for the reply, really appreciate it How much you reckon it will cost? Also, can I do this at any decent phone recovery shop? As stated previously, really want to avoid sending the phone back to the US. Once again thanks!

i paid $35 3 years ago(?) at a local repair shop.
The Following User Says Thank You to simms22 For This Useful Post: [ View ]
9th December 2014, 09:47 PM   |  #6  
OP Member
Flag Amsterdam
Thanks Meter: 1
 
43 posts
Join Date:Joined: Jun 2011
@simms22: ordered a USB portal online and replaced it by myself. Phone works again. Thanks for the tip!
Post Reply Subscribe to Thread

Tags
battery, battery android charging, charging battery, cm11
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes