5,814,863 Members 48,667 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Issue with clock displaying incorrect time

Tip us?
 
jedinegotiator
Old
#1  
jedinegotiator's Avatar
Senior Member - OP
Thanks Meter 10
Posts: 254
Join Date: May 2011
Location: Roanoke
Default [Q] Issue with clock displaying incorrect time

I am having an issue with my clock displaying the wrong time on occasion. I am using SlimKAT Stable 3.0 with Franco Kernel R37.

Sometimes my phone will display the time one hour earlier than it really is. I live in the Eastern Standard Timezone. So for example if it is actually 7pm my phone my say that it is 6pm. In the clock settings I have set my home timezone as Eastern Standard (GMT -4). When my phone is showing the wrong time it now has two clocks. The main clock will say 6pm and there is a second clock that says 7pm at home. It is like my phone thinks that I am traveling and I am not in my own time zone.

Restarting my phone fixes the problem every time but it is very annoying because I depend on my phone to be my alarm clock. I also noticed today that turning on airplane mode and then turning it back off will also fix the problem.

Any ideas on what may be causing this?
 
jedinegotiator
Old
#2  
jedinegotiator's Avatar
Senior Member - OP
Thanks Meter 10
Posts: 254
Join Date: May 2011
Location: Roanoke
Quote:
Originally Posted by jedinegotiator View Post
I am having an issue with my clock displaying the wrong time on occasion. I am using SlimKAT Stable 3.0 with Franco Kernel R37.

Sometimes my phone will display the time one hour earlier than it really is. I live in the Eastern Standard Timezone. So for example if it is actually 7pm my phone my say that it is 6pm. In the clock settings I have set my home timezone as Eastern Standard (GMT -4). When my phone is showing the wrong time it now has two clocks. The main clock will say 6pm and there is a second clock that says 7pm at home. It is like my phone thinks that I am traveling and I am not in my own time zone.

Restarting my phone fixes the problem every time but it is very annoying because I depend on my phone to be my alarm clock. I also noticed today that turning on airplane mode and then turning it back off will also fix the problem.

Any ideas on what may be causing this?
Help!
 
beaver2233
Old
#3  
Senior Member
Thanks Meter 481
Posts: 2,008
Join Date: Feb 2011
Location: Sydney
what happens if you have automatic time zone selected?

Sent from my Nexus 5 using Tapatalk
 
mistahseller
Old
#4  
mistahseller's Avatar
Senior Member
Thanks Meter 193
Posts: 798
Join Date: Mar 2013
Location: Saint Louis
The obvious is do you have automatic time zone selected? Who is your carrier? Do you have GPS issues on your nexus? Maybe post in slimkat thread to see if anyone else experiences this

Sent from The Deathstar

---------- Post added at 08:00 AM ---------- Previous post was at 07:59 AM ----------

What I was referring to with GPS is that if you have the wonky GPS problem it could think you are somewhere else and then notice you arent. You know what I am saying.

Sent from The Deathstar
 
howard bamber
Old
#5  
howard bamber's Avatar
Senior Member
Thanks Meter 178
Posts: 1,272
Join Date: Jun 2012
Location: Southport
I know how to cure it. Turn off auto time zone. Download "atomic clock" that will sync it with.... An atomic clock any time you want, or when it is programmed to by you

Sent by mobile telephone.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes