Samsung Galaxy Note Edge Hands On – XDA TV

Perhaps one of the more peculiar announcements this year was the curved edge-screened … more

Nova Launcher Update Brings Lollipop Functionality and Feel

One of the most popular third party launcher on Android, Nova Launcher, has just … more

Check Your I/O Usage with Iotop for Android

Ever needed to check the I/O usage of apps? If so, you probably tried searching for an iotop … more

T-Mobile HTC One M8 Gets Selfie-Friendly Android 4.4.4 OTA

The T-Mobie variant of HTC One (M8) just now received an over-the-air update … more
Post Reply

Lost all app data after crash and forced reboot

OP birkholze

5th March 2014, 07:20 PM   |  #1  
OP Member
Flag Clyde
Thanks Meter: 25
 
65 posts
Join Date:Joined: Jan 2009
More
Hi, did a quick search but couldn't find anything.

I experienced something very strange and depressing this morning. Running AOSPA 4.1 beta, I experienced a bug with pie that locked my phone up after rotating it while pie was active. Only way I could find out of it was to hold the power button until it rebooted the phone.

When my phone booted back up, I was greeted with the message "System UIDs Inconsistent." All of my gapps started force closing at random times and ALL OF MY APP DATA was gone. All of my apps were still there, just all of the data was gone so every time I opened one, it was like the first time it has ever been launched. It's like a factory reset was performed but all of my user apps are still installed.

I wiped system and reinstalled the rom and gapps hoping to solve it but it didn't fix anything. Used Titanium Backup to try to restore the backed up system ID but it said the current ID matches what's backed up. I then ran fix permissions in TWRP and that fixed the UID message and gapps force closing but my app data is still gone.

I'm hoping the data is still there, just inactive/hidden. My free space on SD seems to be a GB or 2 lower than before the problem but it's been a few days since I checked that so it might be the same as before the issue.

My last backup with Titanium was a few weeks ago so I'm really trying to avoid restoring that if there is some other solution to restore the app data if it's still there. All that Swordigo progress gone with only the final boss to go!

Any help is greatly appreciated.
5th March 2014, 08:53 PM   |  #2  
rootSU's Avatar
Senior Member
Flag Oxenhope, West Yorkshire, UK
Thanks Meter: 12,176
 
23,188 posts
Join Date:Joined: Aug 2010
More
Have you tried browsing the app data to see what's there?

I've had similar things happen across multiple devices and typically only a restore has helped.

Sent from my Nexus 5 using Tapatalk
6th March 2014, 01:45 AM   |  #3  
OP Member
Flag Clyde
Thanks Meter: 25
 
65 posts
Join Date:Joined: Jan 2009
More
The data/data folder has a folder for each of my apps but all that's in most of them is a cache folder or lib file but nothing else. I guess it's just gone.

Sent from my Nexus 5 using Tapatalk
6th March 2014, 01:54 AM   |  #4  
El Daddy's Avatar
Forum Moderator
Flag Roseville, MN
Thanks Meter: 4,041
 
3,661 posts
Join Date:Joined: May 2008
Donate to Me
More
Try fix permissions in recovery.
6th March 2014, 05:22 PM   |  #5  
OP Member
Flag Clyde
Thanks Meter: 25
 
65 posts
Join Date:Joined: Jan 2009
More
Quote:
Originally Posted by El Daddy

Try fix permissions in recovery.

Fix permissions solved the UID error but didn't fix the issue with the apps having no data.
6th March 2014, 11:30 PM   |  #6  
IRX120's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 649
 
1,820 posts
Join Date:Joined: May 2012
More
I haven't got my n5 yet but on pure stock on my nexus 4 I had a forced reboot (do have a custom kernel) and all my Google app data was gone (account, music, ect...) I think it has something to do with fsync being off possibly?

Sent from my Nexus 4 using Tapatalk
7th March 2014, 02:41 PM   |  #7  
OP Member
Flag Clyde
Thanks Meter: 25
 
65 posts
Join Date:Joined: Jan 2009
More
I just gave up and restored to an old backup. Lesson learned... Auto backup now enabled.

Sent from my Nexus 5 using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Nexus 5 Q&A, Help & Troubleshooting by ThreadRank