Unofficial Android 4.4 Lands on Three Mediatek Devices

For the last few years, devices with MTK systems-on-chip haven’t received much … more

MultiImagePicker Library for Multiple Image Selection

App developmentcan be done in more than a handful of ways. You can write every single … more

Shoot Troubles, Not Users w/ Alex Boag-Munroe – XDA:DevCon 2014

In presenting the various sessions from XDA:DevCon 2014, weve mainly … more

Oppo Releases ColorOS for the Find 5… Poorly

Almost every OEM has taken the liberty of creating its own incarnation of the Android OS. … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Migrating SMS/MMS from Nexus 4 to Nexus 5

OP benjamin831

22nd August 2014, 09:14 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Sep 2011
Hi guys,

I'm trying to migrate all my text messages including threaded group MMS from my Nexus 4 to my new Nexus 5. On my N4, I was using the stock messaging app, not hangout as my default messaging service.

I used My Backup Pro to migrate all the stuff over. It worked, sorta. All times on my threads were set to "5:02am" which is probably when the transfer finished. Therefore they're all chronologically jumbled.

Furthermore the MMS threads didn't show up properly. I would only see my response in the group thread.

PS. I downloaded the stock messaging app to use on my Nexus 5. And all these problems are shown on that app. Would you think using Hangout as default will change this?

I was wondering whether you guys had similar experiences and if you know any better ways to go about doing this again.

Ben
Last edited by benjamin831; 22nd August 2014 at 09:22 PM.
22nd August 2014, 09:31 PM   |  #2  
_MetalHead_'s Avatar
Senior Member
Flag Chicagoland
Thanks Meter: 2,506
 
5,981 posts
Join Date:Joined: Jun 2010
More
I use SMS Backup and Restore. Never had an issue with it. Timestamps are all what they should be.

Sent from my Moto X
22nd August 2014, 09:45 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Sep 2011
Quote:
Originally Posted by _MetalHead_

I use SMS Backup and Restore. Never had an issue with it. Timestamps are all what they should be.

Sent from my Moto X

That's great news. Does it work for MMS?
22nd August 2014, 09:58 PM   |  #4  
_MetalHead_'s Avatar
Senior Member
Flag Chicagoland
Thanks Meter: 2,506
 
5,981 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by benjamin831

That's great news. Does it work for MMS?

Yup! Just make sure you check the box for MMS. I think it's free so there's no reason to not try it.

Sent from my Moto X
22nd August 2014, 10:09 PM   |  #5  
Senior Member
Thanks Meter: 92
 
274 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by benjamin831

That's great news. Does it work for MMS?

According to the description:

Quote:

Please note that MMS (Picture/Audio/Video messages) support is currently in BETA.

So you may or may not get your MMS.
22nd August 2014, 10:39 PM   |  #6  
_MetalHead_'s Avatar
Senior Member
Flag Chicagoland
Thanks Meter: 2,506
 
5,981 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by mbellot

According to the description:



So you may or may not get your MMS.

Just used it the other day, MMS restored just fine for me.

Sent from my Moto X
22nd August 2014, 11:20 PM   |  #7  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Sep 2011
Quote:
Originally Posted by _MetalHead_

Just used it the other day, MMS restored just fine for me.

Sent from my Moto X

Cool, I'll give it a shot. Are you MMS group threaded or just pictures?
23rd August 2014, 01:41 AM   |  #8  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Sep 2011
Okay, so I deleted the stock Android messaging app from my N5 and used Hangout as my default messaging app. And it seems like everything got transferred properly. Timestamps are all okay.

The only problem now are group MMS threads. When I open it, it just shows my responses. All the group participant responses don't show up.

Any clues?
23rd August 2014, 02:06 AM   |  #9  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Sep 2011
I attached two pics to illustrate what I'm talking about. The group thread MMS only contains my response and the participant's response it buried in their SMS thread.
Last edited by benjamin831; 23rd August 2014 at 02:10 AM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes