Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Nexus 5 ART Runtime Problem

OP NyquilOverdose

22nd February 2014, 05:01 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Feb 2014
Hey everyone,

I've been using my Nexus 5 since November and I have to say I love it. I have the phone rooted, running stock 4.4.2.

Here's my problem: when I try to switch to ART runtime in developer settings, I get the regular prompt and my phone reboots. But it doesn't switch to ART, it just does a regular reboot. I used to be able to switch between the two runtimes easily until recently. The only modifications I have are root access, custom recovery, and the Xposed framework with some modules. Do any of you guys know what's going on with my phone? I think something might be corrupted or incompatible in my software.

Thanks a lot for the help!

Current Devices: Google Nexus 5 and Nexus 10, both running KitKat 4.4.2
22nd February 2014, 05:03 AM   |  #2  
monkeypaws's Avatar
Senior Member
Thanks Meter: 533
 
1,936 posts
Join Date:Joined: Feb 2012
Before someone flames you I'll be polite. Xposed is not supported at this time that's why its not switching to art. To activate. Unsitall and remove any closed framework mods and xposed itself. Then it should let you.

Sent from my Nexus 5 using xda app-developers app
The Following 2 Users Say Thank You to monkeypaws For This Useful Post: [ View ]
22nd February 2014, 01:12 PM   |  #3  
Mr hOaX's Avatar
Senior Member
Thanks Meter: 1,703
 
502 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by NyquilOverdose

Hey everyone,

I've been using my Nexus 5 since November and I have to say I love it. I have the phone rooted, running stock 4.4.2.

Here's my problem: when I try to switch to ART runtime in developer settings, I get the regular prompt and my phone reboots. But it doesn't switch to ART, it just does a regular reboot. I used to be able to switch between the two runtimes easily until recently. The only modifications I have are root access, custom recovery, and the Xposed framework with some modules. Do any of you guys know what's going on with my phone? I think something might be corrupted or incompatible in my software.

Thanks a lot for the help!

Current Devices: Google Nexus 5 and Nexus 10, both running KitKat 4.4.2

Xposed Module is incompatible with ART
It's causing this issue

Sent from my Nexus 5 using Tapatalk
The Following User Says Thank You to Mr hOaX For This Useful Post: [ View ]
22nd February 2014, 05:53 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Feb 2014
Thanks guys! I think I'll hold off on art because I use xposed a lot.

Current Devices: Google Nexus 5 and Nexus 10, both running KitKat 4.4.2
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes