5,597,261 Members 40,871 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Nexus 5 camera does not record video

Tip us?
 
shahidhussain
Old
#1  
Member - OP
Thanks Meter 7
Posts: 81
Join Date: Jan 2010
Question [Q] Nexus 5 camera does not record video

My wife has Nexus 5 (it is completely stock and unrooted with unlocked bootloader) running running Android 4.4.2. Recently, the stock camera app stopped recording videos. Tapping the record button does not do anything while camera works perfectly in photo mode. I factory reset the phone but the problem persists. Any suggestions? Thanks in advance.
 
roydondsa
Old
#2  
Member
Thanks Meter 4
Posts: 35
Join Date: Dec 2013
lock the bootloader and send it back
 
lichti1901
Old
#3  
lichti1901's Avatar
Recognized Contributor
Thanks Meter 3237
Posts: 2,952
Join Date: Sep 2010
Location: Riding my Bike

 
DONATE TO ME
Quote:
Originally Posted by shahidhussain View Post
My wife has Nexus 5 (it is completely stock and unrooted with unlocked bootloader) running running Android 4.4.2. Recently, the stock camera app stopped recording videos. Tapping the record button does not do anything while camera works perfectly in photo mode. I factory reset the phone but the problem persists. Any suggestions? Thanks in advance.
Try to clear data and cache from camera in settings.
If that doesnt work either and you really have done the factory reset, you have to send it to repair bc of an hardware deffect.
///DevHost for my rastakat builds black&white themed with some extra goodies ///
Android File Host also for my rastakat updates
github for my Code

Sent from my Nexus 5 or HTC ONE M8
and my second Baby
Cube Stereo Super HPC 140 Race


 
shahidhussain
Old
#4  
Member - OP
Thanks Meter 7
Posts: 81
Join Date: Jan 2010
Quote:
Originally Posted by lichti1901 View Post
Try to clear data and cache from camera in settings.
If that doesnt work either and you really have done the factory reset, you have to send it to repair bc of an hardware deffect.
I will try that but I think factory resetting clears cache, anyway. The phone camera worked fine previously but now suddenly it stopped.

Thanks anyway.
 
ketonkss4
Old
#5  
ketonkss4's Avatar
Senior Member
Thanks Meter 17
Posts: 192
Join Date: Jan 2011
Location: Minneapolis
I have the same problem, when I change the camera app to record nothing happens when I press the red record button. I think the problem started when I upgraded to 4.4.2

Sent from my Nexus 5 using Tapatalk
Original Member of the Pitchfork Committee Midwest Chapter
(1) Nexus 4 16 GB ordered Nov.13th 8:58PST (1-2 day Shipping est) Status: In the End it Never came (*Kanye shrug*)
(2) Nexus 4 16 GB ordered Dec. 5th (Team 5-6 weeks) Status: Delivered
 
lichti1901
Old
(Last edited by lichti1901; 23rd January 2014 at 02:07 PM.)
#6  
lichti1901's Avatar
Recognized Contributor
Thanks Meter 3237
Posts: 2,952
Join Date: Sep 2010
Location: Riding my Bike

 
DONATE TO ME
Quote:
Originally Posted by shahidhussain View Post
I will try that but I think factory resetting clears cache, anyway. The phone camera worked fine previously but now suddenly it stopped.

Thanks anyway.
And you flashed the right one? Hammerhead-4.4.2

Like i said before, if that doesnt help, you have to send it back to get a replacement.

Quote:
You need to uncompress each download before use, which creates a new directory for that exact download. That directory contains a ./flash-all.sh script, which handles the various operations, installs the necessary bootloader, baseband firmware(s), and operating system. Note that this operation deletes all user data by default
Make yure that data gets wiped also! Dont forget to backup your sdcard bc it gets also wiped.
///DevHost for my rastakat builds black&white themed with some extra goodies ///
Android File Host also for my rastakat updates
github for my Code

Sent from my Nexus 5 or HTC ONE M8
and my second Baby
Cube Stereo Super HPC 140 Race


The Following User Says Thank You to lichti1901 For This Useful Post: [ Click to Expand ]
 
shahidhussain
Old
#7  
Member - OP
Thanks Meter 7
Posts: 81
Join Date: Jan 2010
Quote:
Originally Posted by lichti1901 View Post
And you flashed the right one? Hammerhead-4.4.2
I did not flash anything. The phone was OTA updated. Please note that the phone received OTA update and when I applied it, it completed its process but did not update (it was still on older android version) and this happened several times (I mentioned this on a separate thread here on XDA old post).
 
shahidhussain
Old
#8  
Member - OP
Thanks Meter 7
Posts: 81
Join Date: Jan 2010
Quote:
Originally Posted by lichti1901 View Post
And you flashed the right one? Hammerhead-4.4.2

Like i said before, if that doesnt help, you have to send it back to get a replacement.


Make yure that data gets wiped also! Dont forget to backup your sdcard bc it gets also wiped.
I downgraded Nexus 5 from Android 4.4.2 to 4.4 and now the camera is working fine. But I am afraid of updating it back to 4.4.2.
 
gee2012
Old
#9  
gee2012's Avatar
Recognized Contributor
Thanks Meter 2541
Posts: 7,189
Join Date: Jul 2010
Location: Heerlen
Quote:
Originally Posted by shahidhussain View Post
I downgraded Nexus 5 from Android 4.4.2 to 4.4 and now the camera is working fine. But I am afraid of updating it back to 4.4.2.
Flash the whole 4.2.2 stock rom in fastboot bro, i have no issues with video recording both on Dalvik and Art runtime
USE Search: /this thread /all threads/Google before posting your question, you`re most likely not the first one having this issue
The Following User Says Thank You to gee2012 For This Useful Post: [ Click to Expand ]
 
shahidhussain
Old
#10  
Member - OP
Thanks Meter 7
Posts: 81
Join Date: Jan 2010
Quote:
Originally Posted by lichti1901 View Post
And you flashed the right one? Hammerhead-4.4.2

Like i said before, if that doesnt help, you have to send it back to get a replacement.


Make yure that data gets wiped also! Dont forget to backup your sdcard bc it gets also wiped.
Quote:
Originally Posted by gee2012 View Post
Flash the whole 4.2.2 stock rom in fastboot bro, i have no issues with video recording both on Dalvik and Art runtime
Yes, I did it. Flashed the stock 4.4.2 and everything seems to work fine. However, when I tried updating using OTA after downgrading the update failed and stopped with "Error" message. After flashing 4.4.2 from scratch will hopefully allow smooth future OTA updates. Thanks everyone.

Tags
camera app, nexus 5, video issue, video recording
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes