Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Nexus 5 doesn't realize it's connected to PC

OP Dr. Cyanide

27th August 2014, 07:04 PM   |  #1  
OP Member
Thanks Meter: 20
 
79 posts
Join Date:Joined: Sep 2012
I've seen many solutions for the reverse, but not for this problem.

I've got my Nexus 5 connected to my PC right now. I'm trying to copy files off of it, but the Nexus doesn't realize it's connected to the PC. With Android debugging on, Windows realizes there's an "Unknown USB Device" connected, but Android doesn't recognize the computer is connected at all. I've tried the other computer in our house and had the same issue.

I'm running on 4.4.2, so it shouldn't be something too out there, but I can't figure out what else to do.
27th August 2014, 07:08 PM   |  #2  
rootSU's Avatar
Senior Member
Flag Oxenhope, West Yorkshire, UK
Thanks Meter: 13,332
 
24,414 posts
Join Date:Joined: Aug 2010
More
On the other PC, did you use a different cable?

Sent from my Nexus 5 using Tapatalk
27th August 2014, 07:20 PM   |  #3  
OP Member
Thanks Meter: 20
 
79 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by rootSU

On the other PC, did you use a different cable?

Sent from my Nexus 5 using Tapatalk

Using a different cable I was able to get the Tethering options to show up. Activating Tethering, the Nexus 5 was recognized as a "USB Composite Device". Trying to manually specify the USB driver to use hasn't changed anything.
27th August 2014, 07:24 PM   |  #4  
rootSU's Avatar
Senior Member
Flag Oxenhope, West Yorkshire, UK
Thanks Meter: 13,332
 
24,414 posts
Join Date:Joined: Aug 2010
More
With the different cable, deactivate tethering then delete the device in device manager. See if anything else shows up. Could be cable issue, could be phone port issue

Sent from my Nexus 5 using Tapatalk
27th August 2014, 07:35 PM   |  #5  
OP Member
Thanks Meter: 20
 
79 posts
Join Date:Joined: Sep 2012
Got it working. At some point I unchecked both the MTP and PTP connection options, but for whatever reason plugging the phone back into the computer didn't make the notification pop up. I had to go to Settings -> Storage -> (menu) USB computer connection in order to turn it back on.

Sorry for the trouble.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes