FORUMS

[Q] Nexus 5 Wi-Fi issue: hardware or software ?

4 posts
Thanks Meter: 0
 
By iperetta, Junior Member on 23rd August 2014, 10:03 AM
Post Reply Subscribe to Thread Email Thread
Hi, guys

I know it is a recurring subject, but every thread I've found says to reset or do some trick with the OS to get it solved...

My Nexus 5's Wi-Fi hardware seems to be off (or non-existent). I took some screenshots, which I include here.

1. The "Settings" screenshot shows the "gray-shaded" Wi-FI button;

2. The "Status" screenshot shows that there is no Wi-Fi MAC address available;

3. The "INFO" screenshot was taken from dialing << *#*#4636#*#* >> (wifi status testing) and shows that Wi-Fi is not recognized

The thing here is that this is my second Nexus 5. The first one had the same error and Google replaced me with this one. First time, it took less than 1 month to the error to show up. This time, it took more than 1 month.

If you guys could at least identify this as a hardware or software issue, I would appreciate very much.

Thanks!
Attached Thumbnails
Click image for larger version

Name:	Screenshot_gray_wifi.png
Views:	248
Size:	175.0 KB
ID:	2908775   Click image for larger version

Name:	Screenshot_no_macadd.png
Views:	236
Size:	175.0 KB
ID:	2908776   Click image for larger version

Name:	Screenshot_INFO.png
Views:	243
Size:	201.0 KB
ID:	2908777  
 
 
23rd August 2014, 03:08 PM |#2  
Junior Member
Thanks Meter: 0
 
More
It happened to me too, please help.
In this post http://forum.xda-developers.com/goog...stuck-t2721643
23rd August 2014, 05:12 PM |#3  
Recognized Contributor
Thanks Meter: 1,323
 
More
Quote:
Originally Posted by anunymos

It happened to me too, please help.
In this post http://forum.xda-developers.com/goog...stuck-t2721643

There is good info in that thread.

1) Delete /data/misc/wifi and /data/misc/dhcp and reboot.
2) Try a different ROM/kernel, is a kernel issue a lot of times.
23rd August 2014, 05:14 PM |#4  
OP Junior Member
Thanks Meter: 0
 
More
Hardware problem
I've just spoke to Google's support team and they told me it is a hardware problem. It seems I am terrible unlucky to get this problem twice with different devices (same model). Well, I'm giving it a shot and asking for my third replacement. Supposedly, it is the fair way to go. I strongly advice if you got the same problem to ask Google for a replacement.

Thanks to all that tried to help.
24th August 2014, 07:41 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Google does not claim that this is a hardware problem, but they immediately offered to replace the product.
I do not believe this is a hardware problem because the product worked great, and only after a few updates 4.4.1, 4.4.2, 4.4.3 and 4.4.4 is screwed.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes